WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#13424 closed defect (bug) (fixed)

Admin Dashboard doesn't remember layout prefs

Reported by: ipstenu Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Administration Keywords:
Focuses: Cc:
PR Number:

Description

My dash looks like this:

Right Now --------- WordPress Dev Blog
Recent Comments --- Recent Drafts
(nothing) --------- Other WordPress News

and I want my Dash to be:

Right Now --------- Recent Drafts
Recent Comments --- WordPress Dev Blog
(nothing) --------- Other WordPress News

So I drag'n'drop my boxes as I want, fiddle around some, hit refresh and they show up back like they did in the begining.

Tested on WordPress 3.0-beta2-14697 (multisite) and WordPress 3.0-beta2-14676 (singlesite and multisite)

Change History (24)

#1 @ocean90
10 years ago

Which browser? Works fine for me.

#2 @ipstenu
10 years ago

Chrome and Firefox on XP.

#3 @ryan
10 years ago

(In [14726]) Remove old metaboxorder settings. see #13424

#4 @ryan
10 years ago

  • Milestone changed from Unassigned to 3.0

After updating to latest svn and running the upgrade, search the usermeta table for %metaboxorder% and %meta-box-order% for the current user. What's there?

#5 @ipstenu
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

SVN seems to have corrected it. I have the following meta-box and metabox tables:

meta-box-hidden_nav-menus
meta-box-order_dashboard
meta-box-order_nav-menus
meta-box-order_page
metaboxhidden_dashboard
metaboxhidden_nav-menus	
metaboxhidden_page
metaboxhidden_post

Compared this to my other site (not updated, still not working) which has this:

meta-box-hidden_dashboard
meta-box-hidden_post
meta-box-order_dashboard
metaboxhidden_dashboard	
metaboxhidden_link
metaboxhidden_nav-menus	
metaboxhidden_page
metaboxhidden_post

Upgraded to trunk, everything runs happily and the metas are still as follows:

meta-box-hidden_dashboard
meta-box-hidden_post
meta-box-order_dashboard
metaboxhidden_dashboard
metaboxhidden_link
metaboxhidden_nav-menus
metaboxhidden_page
metaboxhidden_post

#6 @mynetx
9 years ago

  • Cc mynetx added
  • Resolution fixed deleted
  • Status changed from closed to reopened

I upgraded from 2.9.2 to 3.0 by manually uploading the tar.gz files. Now when I move around the boxes on my Dashboard and then reload the page, the boxes are again in their default order.

I have:

metaboxhidden_dashboard
mx_meta-box-order_dashboard
meta-box-order_dashboard

#7 @markmcwilliams
9 years ago

  • Milestone changed from 3.0 to 3.0.1

#8 follow-up: @ryan
9 years ago

Delete mx_meta-box-order_dashboard.

#9 in reply to: ↑ 8 @mynetx
9 years ago

Replying to ryan:

Delete mx_meta-box-order_dashboard.

Thanks, that worked. How did these wrong meta keys find their way into my database? Looks like a multisite 3.0-upgrade bug assumes.

#10 @ryan
9 years ago

2.9.2 used a prefixed key. 3.0 does not. The old, prefixed key should have been deleted during upgrade, but evidently that didn't happen here.

#11 @shidouhikari
9 years ago

  • Cc shidouhikari added

I also have this issue, when I upgrade it reverts to default and I lose my style.

What's the option name in 2.9.2 and in 3.0, so that I can fix it in my database?

#12 @ryan
9 years ago

In the usermeta tables, look for *meta-box-order_dashboard where * is your DB prefix, usually wp_. Delete that.

Are those seeing this using multisite? The usermeta cleanup is run only for the main site. Maybe the is_main_site() check is not working correctly during upgrade.

#13 @shidouhikari
9 years ago

Before upgrading I have a *metaboxorder_dashboard row, after upgrading it's gone.

It happens just before upgrading to 3.0, I don't even have the chance to enable network.

#14 @nacin
9 years ago

Is this a reproducible error, or is it a fluke that these keys didn't get cleared? worksforme?

#15 @ryan
9 years ago

I'm not sure why they aren't being cleared. I've not been able to reproduce.

#16 follow-up: @shidouhikari
9 years ago

It happens everytime I test upgrade.

If I could just be informed of where layout is stored before and how to port it manually to 3.0, I could try to recover it and move on.

#17 @ryan
9 years ago

http://core.trac.wordpress.org/browser/trunk/wp-admin/includes/upgrade.php?rev=15374#L1135

That's the line that is supposed to be removing these. All of those usermeta options need to be removed.

#18 in reply to: ↑ 16 ; follow-up: @westi
9 years ago

  • Keywords reporter-feedback added

Replying to shidouhikari:

It happens everytime I test upgrade.

If I could just be informed of where layout is stored before and how to port it manually to 3.0, I could try to recover it and move on.

Are you able to detail the steps you use to reproduce?

I assume you do a clean install of 2.9.2, re-order the dash, upgrade to 3.0?

#19 @nacin
9 years ago

  • Milestone changed from 3.0.1 to Awaiting Review

#20 in reply to: ↑ 18 @shidouhikari
9 years ago

Replying to westi:

I assume you do a clean install of 2.9.2, re-order the dash, upgrade to 3.0?

No, I upgrade my live sites and it gets disorded.

Well I'm just gonna reorder boxes back to their places after upgrading, I hope that solves the issue :p

#21 @gazouteast
9 years ago

I've seen this on several sites - standalone and MS home site (haven't checked sub sites) - both 2.9.2 -> 3.x and 3.0 ->3.0.1 not sure about the 3.0.l fresh installs, would need to check.

Particularly annoying when trying to keep the wp-stats widget at top right of dashboard - it the first thing I look for on login.

Suggest the database cleaner mentioned above is retained at least for the next several version upgrades, just to be sure it's getting caught.

#22 @jane
9 years ago

  • Keywords reporter-feedback removed

#23 @nacin
9 years ago

  • Milestone changed from Awaiting Review to 3.0

This seems fixed -- closing on 3.0. Re-open with additional feedback or reports of the problem.

#24 @nacin
9 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.