Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13443 closed defect (bug) (worksforme)

Media Library Search Results Not Complete

Reported by: jenz Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Media Keywords: reporter-feedback
Focuses: Cc:


When searching for an image by the title field - on a site with several thousand images - it will not show up in the search results unless it has been within the last 5000 images uploaded (I cannot get an exact number).

How to reproduce:
1.Go to Admin > Media > Library

  1. Find an image that you uploaded more than 2 months ago using the drop down month list (just to make sure it is not recent). Copy the title.
  2. Paste in the title in the "Search Media" search form.

No results will show up.

*This is not an issue with 2 sites I tested that have less than 500 images in the media library but it shows up with another site that has 72,000+ images.

Attachments (1)

13443-images.php (720 bytes) - added by hakre 6 years ago.
Script to generate thousand of images.

Download all attachments as: .zip

Change History (18)

#1 @hakre
6 years ago

So what do you think, will that happen on site where I right now upload 50 000 images and then test? Would that be a potential case to reproduce or would I need to wait for two month to test (just asking for clarification).

#2 @hakre
6 years ago

I must admit, that this issue is hard to reproduce. I'm currently trying to get close to those numbers, but it will take some time.

#3 @hakre
6 years ago

What I can report performance wise, is that


Loads really slow on the article that has 2900+ images attached. This was while doing uploads and while not doing uploads. I do not know the details on top of my head how the gallery is queried / and or this is related to the generation of the html sourcecode.

#4 @hakre
6 years ago

Hard to test w/o sorting in the Media Library: #9259

#5 @hakre
6 years ago

Images (6,968) and still working. I'll continue to upload.

#6 @hakre
6 years ago

Images (14,968) and still working. I'll continue to upload.

#7 @hakre
6 years ago

Okay I might just have crashed my blog with this beta-test. Anyway, I need to get some sleep now. I'll take care of this some hours later.

#8 @hakre
6 years ago

Images (19,585) and still working. But uploads are sheduled. should copy up in the direction of 30k files soon. Post with gallery does not load any longer as it seems.

Caching pages is great but it looks like that this does not always work in the end.

#9 @hakre
6 years ago

Images (29,336) and still working.

#10 @hakre
6 years ago

Images (35,674) and still working. I hope I do not need to go up 75k images to reproduce.

#11 @hakre
6 years ago

Images (37,550) and still working. But searching in the iframe scripts starts to not list all entries.

#12 @hakre
6 years ago

Images (54,884) and still working. Really not easy to test. I try to push towards the direction of 75k as the reporter suggests. But Since now I really did not encounter any difficulties to search for older images.

If the original reporter could provide some more details that would be really helpfull.

#13 @hakre
6 years ago

  • Component changed from General to Media
  • Keywords reporter-feedback added; media library search results removed

6 years ago

Script to generate thousand of images.

#14 @hakre
6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

With a total Images of 84 565 of which 78 496 were assigned to a posts gallery, I can not reproduce.

This is how I tested:

  • Generated 90 0000 Images
  • Uploaded most of them to a single posts gallery.
  • Tested to search for a picture on the same blog that is older then two month.
  • As long as the search results showed the picture the test succeeded.
  • If the search results to not show that picture, the test fails.

The test always succeeded during testing. I'll close this as worksforme. The original reporter should provide more information so it is possible to better reproduce. Better information could be exact version numbers of Server OS, Browser incl. Plugins, Webserver, Database Server and the filesize(s) of the images this is about.

Additionally you can provide a database dump of the media's meta-data information which is searched through.

#15 @hakre
6 years ago

While doing the cleaning up afterwards, I run over an related: #11114

#16 @nacin
6 years ago

  • Milestone Unassigned deleted

#17 @nacin
6 years ago

Very thorough work on this, hakre. Nice job.

Note: See TracTickets for help on using tickets.