WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 16 months ago

#13464 closed defect (bug) (worksforme)

Post editor/meta boxes collapse their margins/spacing

Reported by: RobertWHurst Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: UI Keywords: reporter-feedback
Focuses: Cc:

Description

I've playing with the custom post type in the current trunk. The editor module is broken. The buttons allowing for switching between HTML and WYSIWYG editing. There also is an empty div called #ed_toolbar pushing the rich text editor out of position. also there is a problem with the spacing between the editor module and any module placed beneath it.

I've attached a picture outlining the problems.

Attachments (1)

error.png (79.6 KB) - added by RobertWHurst 4 years ago.
Issues with the custom post type editor

Download all attachments as: .zip

Change History (13)

RobertWHurst4 years ago

Issues with the custom post type editor

comment:1 dd324 years ago

  • Component changed from Editor to Post Types
  • Keywords reporter-feedback added

What browser are you experiencing this under? Both the visual and the Javascript appear fine for me.

Furthermore, What is the post_type registration you're using? I'm testing with the following:

	register_post_type('note', array('label' => 'Notes', 'query_var' => 'note', 'public' => true, 'hierarchical' => false, 'supports' => array('editor', 'page-attributes', 'title', 'comments') ) );

comment:2 dd324 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme unless reporter can provide more details to pinpoint any issues. Looks like bad CSS to me.

comment:3 RobertWHurst4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Sorry I was away on a bit of a vacation. I'm using Firefox 3.6 on Mac OS 10.6.3. I've used the same method. If you have no problems on your end, It could be possible that I have a corrupted install. I'll dump my install and start over, see what happens, then post back here.

comment:4 nacin4 years ago

I've seen this before in some browsers (well, the lack of padding on the meta boxes anyway), and a refresh usually fixes it.

comment:5 RobertWHurst4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Yea Its gone now. That was a bit weird, but its gone now so I guess the problem is solved.

comment:6 nacin4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 nacin4 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:8 pavelevap4 years ago

  • Cc pavelevap@… added
  • Component changed from Post Types to UI
  • Milestone set to 3.0.1
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I am not sure if this is the same problem, but space between boxes is missing (only IE8).

Missing space between boxes is only between Post Editor Area, Excerpt, Trackbacks and Custom fields. Then space is visible (Comments, Slug, Author). The same problem is for Pages (only between Page Editor Area and Custom Fields box).

Another playing with this problem: Missing space between boxes appears maybe only in the left column where there are boxes in right column. So when there is only one column, then spaces are visible. When there are two columns then until right column ends, no space between boxes in the left column is visible... And removing boxes also did not help...

comment:9 nacin4 years ago

  • Milestone changed from 3.0.1 to Future Release
  • Summary changed from The custom post type editor is broken to The post type editor is broken

Moving this out of 3.0, as it is not a regression.

As indicated above, I have seen this in a limited form, and usually on one of the core post type pages, not necessarily a custom post type.

comment:10 nacin4 years ago

  • Summary changed from The post type editor is broken to Post editor/meta boxes collapse their margins/spacing

comment:11 pavelevap4 years ago

This problem appears for me during last months, so it is somehow connected with 3.0 development.

Also switching between TinyMCE and HTML (and switching back) leads to appearing space between Post Editor Area and Excerpt. But thera are still missing spaces between Excerpt - Trackbacks and Trackbacks - Custom fields.

And when leave Post with HTML editor selected and try to create new Post, then in HTML view are all spaces. So it is probably somehow related to TinyMCE.

comment:12 helen16 months ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Doesn't seem to happen anymore.

Note: See TracTickets for help on using tickets.