WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13533 closed defect (bug) (invalid)

Update Network Dashboard Fails

Reported by: jlevandowski Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Multisite Keywords: reporter-feedback
Focuses: Cc:

Description

When using the update network function it fails if you have a dashboard site installed.

Warning! Problem updating http://dashboard.example.com. Your server may not be able to connect to sites running on it.
Error message: Maximum (5) redirects followed

Change History (9)

comment:1 @nacin5 years ago

  • Milestone changed from Unassigned to 3.0
  • Severity changed from normal to blocker

comment:2 @wpmuguru5 years ago

  • Keywords reporter-feedback added
  • Severity changed from blocker to normal

I was able to update a network running a dashboard site http://dashboard.site.com. Taking the blocker off until we have steps to reliably reproduce the problem.

comment:3 @jlevandowski5 years ago

Not sure what is going on. I am running 3.0-beta2-14896 on a shared host (HostGator). If I deactivate the dashboard site the update network functions works. I am using subdomains and have 1 primary site example.com and 1 secondary site 2.example.com in addition to dashboard.example.com. Wildcard DNS is setup using an external provider (GoDaddy). What else can I provide to help resolve this issue. I tried backing up the database and installing it on a localhost machine with subdirectories and it works fine. Can't replicate subdomain using localhost.

comment:4 @nacin5 years ago

Any chance you can try to debug this a bit further?

For reference, this is the URL it would be trying to access: trailingslashit( $siteurl ) . "wp-admin/upgrade.php?step=upgrade_db

comment:5 @jlevandowski5 years ago

I wonder if the key part of the error is "Error message: Maximum (5) redirects followed"

Maybe it is because http://dashboard.site.com/ redirects to http://dashboard.site.com/wp-admin/

comment:6 @jlevandowski5 years ago

I think I have found the issue.

Using http://www.iwebtool.com/http_headers I looked at the response headers.

http://dashboard.site.com responds HTTP/1.1 302 Moved Temporarily with location http://dashboard.site.com/wp-admin/

http://dashboard.site.com/wp-admin/ responds HTTP/1.1 302 Moved Temporarily with location http://dashboard.site.com/wp-admin/ creating an infinite loop.

PHP version on my host is PHP/5.2.13 if that helps.

comment:7 @nacin5 years ago

We're not requesting dashboard.site.com however, we're requesting a specific page within wp-admin directly -- dashboard.site.com/wp-admin/upgrade.php?step=upgrade_db. This page does not require authentication.

http://dashboard.site.com/wp-admin/ should not be serving a 302 to redirect back to itself -- I've never seen that.

Do you have SSL going on anywhere? It looks like we just fetch siteurl directly from the database, with no SSL check.

comment:8 @jlevandowski5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

OK. I figured it out. I have an .htaccess rule set up in wp-admin as follows for security:

order deny,allow
allow from webhost.net
deny from all

Removing this rule fixes it, now I need to figure out how to make it work by adding something to the above .htaccess file.

Sorry for the wild goose chase but maybe this ticket can help others who have the same .htaccess rule issues.

comment:9 @ocean905 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.