WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#13566 closed task (blessed) (fixed)

Category/Tag Converter and importer UI improvements

Reported by: nacin Owned by: nacin
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: Import Keywords: ux-feedback
Focuses: Cc:

Description

Per IRC discussion and other things I've noticed, there are some UI improvements we can make to make the transition a bit more seamless.

Change History (17)

comment:1 nacin4 years ago

  • Owner set to nacin
  • Status changed from new to accepted

comment:2 nacin4 years ago

(In [14968]) Match up plugin slugs with importer slugs when checking if they're installed. They're different for MT and wpcat2tag currently. see #13566

comment:3 nacin4 years ago

(In [14969]) Remove debug. see #13566

comment:4 nacin4 years ago

(In [14970]) Nicer message for an uninstalled/invalid importer. see #13566.

comment:5 nacin4 years ago

[14978]

Revert [14853], [14778], returning tag/cat converter to tools.php and edit-tags.php. Link to import.php instead of the converter directly as it may not be installed. see #13566.

comment:6 nacin4 years ago

Noticing that it seems that WP doesn't know when an importer needs an upgrade. Haven't looked at whether it is a bug in the logic or simply wp.org not returning them.

You'll know when you just get the FYI box, and no "Install Update Now" button.

Other things:

  • Also, it'd be nice to know when the importer is installed, but the plugin isn't active. That should be reflected in the UI somewhere/somehow.
  • After installing an importer, it should give you the choice to activate and then jump right to the importer. Or at least back to import.php. The workflow is currently a lot of steps and it's not very obvious (though people will figure it out). Just need to add some action links if we're coming from import.php I think.

That's all I got for now.

comment:7 dd324 years ago

(In [14985]) Add Importer support to Plugin Install workflow, Offers to Activate Plugin & Run installer, and returning to Imports upon successful Importer Plugin Installation. See #13566

comment:8 follow-up: dd324 years ago

Noticing that it seems that WP doesn't know when an importer needs an upgrade. Haven't looked at whether it is a bug in the logic or simply wp.org not returning them.

Seeing that as well, I'm not sure if its just because the API doesnt know about previous versions, or what. It might be due to the Imports using the "Stable Tag" field, without actually Tagging releases.

Another commit coming up to switch it from attempting to install, to attempting to Activate in the event that the Importer plugin appears to be installed already. Will need a AYS style addition or string modifications to the $popular_importers I believe (They still say "Install <importer text...>")

comment:9 dd324 years ago

Also needs some Cap checks to make sure users can install the plugin or activate it.

comment:10 nacin4 years ago

dd32 in [14986] -- Change Install link to Activate link in Importer if plugin appears to be already installed. See #13566

comment:11 ryan4 years ago

None of the importers have proper tags yet. Once they're all tagged update notices should show properly.

comment:12 in reply to: ↑ 8 ; follow-up: mdawaffe4 years ago

Replying to dd32:

It might be due to the Imports using the "Stable Tag" field, without actually Tagging releases.

That is a problem, but it's not the salient one.

The problem is that those plugins require WP version 3.0 (as specified in their respective readme.txt files). Currently, WP is at 3.0-beta2-15006, which is less than 3.0. So API.wp.org isn't sending back an update response for that plugin, since as far as it can tell, WP 3.0-beta2-15006 can't support the plugin.

Currently API.wp.org just does a naive version_compare(). I guess we should probably only use the leading, numeric part of the version string.

comment:13 in reply to: ↑ 12 mdawaffe4 years ago

Replying to mdawaffe:

I guess we should probably only use the leading, numeric part of the version string.

Fixed. API.wordpress.org now uses everything before the first "-" when comparing version strings.

comment:14 nacin4 years ago

Thanks mdawaffe!

I'm going to leave this ticket open just so we can walk through the importers workflow a few times and see if there are any slight improvements we can make.

comment:15 nacin4 years ago

  • Keywords ux-feedback added

comment:16 nacin4 years ago

  • Component changed from General to Import

comment:17 nacin4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.