WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#13634 closed defect (bug) (fixed)

Empty menus can be selected in the menu widget, but will appear broken

Reported by: guyn Owned by: filosofo
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Menus Keywords: has-patch
Focuses: Cc:

Description

When the widget area is longer than the main content, the widgets get cut off (image attached).

This is a bug in the theme and should not bother most users (I guess).

Attachments (2)

widget-problem.jpg (97.3 KB) - added by guyn 4 years ago.
Have a look at the footer (above the powered by) taken in Chrome
no-menu-widget-fallback.13634.diff (502 bytes) - added by filosofo 4 years ago.

Download all attachments as: .zip

Change History (13)

guyn4 years ago

Have a look at the footer (above the powered by) taken in Chrome

comment:1 nacin4 years ago

  • Keywords reporter-feedback added; theme twenty ten removed

What is that last widget there? We've all been using Twenty Ten for some time, in many cases running with very little content, and thus the widgets will often be longer than the content. I've never seen this.

comment:2 nacin4 years ago

Also, I use Chrome on both Mac and XP and haven't seen this.

comment:3 ocean904 years ago

I can not repdroduce it too, I use the same widgets and a short content: http://grab.by/4EFY
Seems like the last list is broken.

comment:4 nacin4 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme. Please re-open with steps to reproduce.

comment:5 guyn4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from Widget area gets cut off on low content pages/posts to Problem with menu widget

The problem is actually caused by the Menu widget.
I moved it to the top of the sidebar and the problem persist.
Have a look at : http://testing.motif.co.il/
I'm using version 3.0-RC1-15059 all plugins are disabled.
Contact me directly (guy@…) if you want the password for the blog.


comment:6 ocean904 years ago

Your menu widget is included in:

<div class="menu">

But it should be:

<div class="menu-testmenu-container">

testmenu is the name of the menu. What is your menu name?

comment:7 guyn4 years ago

  • Summary changed from Problem with menu widget to Empty menus can be selected in the menu widget, but will appear broken

I double checked the menus page and was able to locate the problem.

When an empty menu is created and selected in the menu widget, the widget will appear broken. I am able to reproduce the problem with additional menues.

Specifically it appears that the pages I added to the menu I created were saved in draft mode, which actually left the menu empty. On a side note, I'm unable to reproduce the "Draft save" for menus, it might be time based.

comment:8 ocean904 years ago

  • Component changed from Themes to Menus
  • Keywords reporter-feedback removed
  • Milestone set to 3.0
  • Owner set to filosofo
  • Priority changed from low to normal
  • Severity changed from minor to normal
  • Status changed from reopened to reviewing

Oh, nice catch, yes if the menu is empty we will fallback to the page list. I think we shouldn't do that.

comment:9 filosofo4 years ago

I agree with ocean90: if the menu widget is empty, it's probably because someone is in the process of building it; the user would have chosen the pages widget if that's what was desired.

Patch no-menu-widget-fallback.13634.diff keeps the menu widget from falling back to the pages widget.

comment:10 ocean904 years ago

  • Keywords has-patch added

comment:11 nacin4 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

(In [15074]) Don't fall back to pages list in the menus widget. props filosofo, fixes #13634.

Note: See TracTickets for help on using tickets.