WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#13644 closed defect (bug) (worksforme)

500 Error on IIS

Reported by: faffoo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

It seems that the 3.0 RC does not work, at all on IIS. You are just recieving a 500 error when you upload the files to an IIS web server. It doesn't even work on localhost.

Is support for IIS in 3.0 being dropped?

Change History (24)

comment:1 faffoo4 years ago

  • Milestone changed from Unassigned to 3.0

comment:2 westi4 years ago

  • Keywords reporter-feedback added; iis 500 error install removed

Is there any information in the error log?

Which version of IIS?

comment:3 faffoo4 years ago

No error log content. Iis version 7. Will not run any page in system. Just crashes with a 500 error. Is iis supported?

comment:4 nacin4 years ago

IIS is supported, in particular version 7. You may wish to try the support forums: http://wordpress.org/support. There are a large number of sites running WordPress on IIS -- including Microsoft -- and if it was other than an IIS configuration issue I imagine we'd hear about it quite quickly.

comment:5 wikichaves4 years ago

I'm not sure if it is part of this thicked.

I've updated my 2.9.2 WP under IIS to 3.0 RC1 and seems to work everything OK, but when i go to the Admin/Edit, the edit.php file never loads (blank screen)
It also happens with the upload.php file

Francisco

comment:6 dd324 years ago

  • Owner dd32 deleted
  • Status changed from new to assigned

Not sure why, But i do notice theres an IIS version of RC1 available at http://wordpress.org/wordpress-3.0-RC1-IIS.zip (From http://wordpress.org/download/release-archive/ )

Can you try enabling WP_DEBUG (Add define('WP_DEBUG', true); to your wp-config.php file and see if there is any error output then?

You may also need to configure PHP to log PHP Errors to file, I dont think IIS likes passing error messages through, and instead 500's. I dont have enough experience with IIS however to know the full details.

comment:7 faffoo4 years ago

The IIS version made no difference. It was a configuration option that I had been changing a few days ago was causing the problem.

I am now faced with another problem. The register link is not working. When you click register it takes you to wp-signup.php and returns a 400 error. Dont no why.

comment:8 dd324 years ago

  • Milestone 3.0 deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

You may find the 400 errors will be fixed with [15081]

comment:9 faffoo4 years ago

  • Milestone set to 3.0
  • Resolution invalid deleted
  • Status changed from closed to reopened

Nope. That dosnt seem to fix the issue. This seems to be a fairly critical feature that is not working. I am getting a 404 error when i click the register link. The file is there though.

comment:10 dd324 years ago

What type of 404 error is it? WordPress generated? or Server generated?

Is the request being passed to the filesystem, or are the Rewrite rules redirecting before it hits the file?

comment:11 faffoo4 years ago

The 404 is server generated. It is not a "nice looking" wordpress generated 404 error. For some reason the server is not recognizing the wp-signup.php file. Very odd. I cant tell wether it is filesystem or rewrite. How can I check? I removed the rewrite rules from web.config and it still didnt work.

comment:12 ruslany4 years ago

  • Cc ruslany@… added

I cannot repro the 404 errors with the latest nightly build of WordPress on my IIS 7 server. When I click register it takes me to http://localhost/wordpress/wp-login.php?action=register and the registration of a new user is successful. How do you get to the wp-signup.php?

comment:13 faffoo4 years ago

Ok. That's weird, I have this set up with the network feature turned on and when I go to that URL it redirects to wp-signup.php and then gives a 404. Could you try the network feature and then see if it works on your server. I can't get this to work on my localhost and the entire package won't even install on my shared hosting account online. It just gives the original 500 error on every page. That is another page however.

comment:14 ruslany4 years ago

I see. I did not know about the network feature before. So I enabled the network feature and tried to register. It takes me to the wp-signup.php page. I can go through the registration process just fine.

I used the network feature that has separate sites as subfolders. I did not try the subdomain option though.

Can you enable detailed error messages in IIS and see if you get more information with the 404 error? You can contact me on http://ruslany.net/contact/ and I can try to help you to troubleshoot this.

comment:15 ryan4 years ago

See #13685 for a multisite, media related IIS rewrite bug.

comment:16 westi4 years ago

  • Keywords iis-support added

comment:17 bloggus4 years ago

I'm using IIS6 and latest WordPress 3.0-RC2. Using isapi_rewrite for SEF links.

I can't see any of this issues at all.

comment:18 bloggus4 years ago

This is probably on IIS7 error, related especially to web.config.

comment:19 faffoo4 years ago

Higuys,

Thanks for all the help. It seems the 404 with the wp-signup has been fixes with the latest nightly build. Dont know what has changed but it worked. Great!

I still have my original problem however, when trying to install on a hosting package online, which is on IIS 7 aswell, I get a 500 error before I try and do anything. Not got a clue!

Best Regards
Faffoo

comment:20 nacin4 years ago

  • Keywords changed from reporter-feedback, iis-support to reporter-feedback iis-support
  • Priority changed from high to normal
  • Severity changed from critical to normal

comment:21 nacin4 years ago

  • Milestone changed from 3.0 to Unassigned

Lack of actionable feedback and steps to reproduce for what appears to be a server configuration issue. Moving to Unassigned.

comment:22 peaceablewhale4 years ago

  • Keywords close added

@faffoo:

Did the IIS error page say anything? If so, would you posting the message here?

Since WordPress 3.0 has been released for sometime, I also suggest closing this as worksforme unless there is reporter-feedback.

comment:23 mrmist3 years ago

  • Keywords reporter-feedback iis-support close removed
  • Resolution set to worksforme
  • Status changed from reopened to closed

No feedback for a number of months, 3.0 in wide use now.

Re-open with feedback if necessary.

comment:24 scribu3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.