WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#1369 closed defect (bug) (invalid)

wp_list_pages() shows blank list item when no title is wanted.

Reported by: anonymousbugger Owned by:
Milestone: Priority: normal
Severity: minor Version: 1.5.1
Component: Template Keywords:
Focuses: Cc:

Description

When calling "wp_list_pages('title_li= ');" is called, a list item is still added without any content. I don't think this item should appear as it makes an unnessecary space appear in most templates.

I doubt this is by design.

Change History (3)

comment:1 @anonymousbugger10 years ago

  • Patch set to No

comment:2 @anonymousbugger10 years ago

this line also needs to be changed:
355: if ( $rtitle_li? )
to
355: if ( $rtitle_li? && !$rtitle_li? == ' ' )

comment:3 @markjaquith10 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Actually, you should be using wp_list_pages('title_li='); with no space. The Codex used to have incorrect information on this :-\

Note: See TracTickets for help on using tickets.