WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13721 closed enhancement (fixed)

Maintenance mode doesn't get disabled after failed upgrade

Reported by: bonjurkes Owned by: dd32
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

WP enables maintenance mode when admin starts an update process (updating themes, plugins etc.) But when an update fails maintenance mode doesn't get disabled and it blocks access to wp admin.

So 2 possible options :

1-) Maintenance mode can get disabled (.maintenance file will be deleted automatically) if some upgrade or installation fails

or

2-) Maintenance mode shouldn't block access to wp-admin section, as each time admin has to delete .maintenance file from ftp when he/she wants to access wp-admin to retry updating process.

WP Version : 3.0 RC2

Change History (8)

comment:1 @ocean905 years ago

  • Component changed from General to Upgrade/Install
  • Owner set to dd32

comment:2 @ryan5 years ago

(In [15139]) Make upgrading global so maintenance_nag() can see it. see #13721

comment:3 @ryan5 years ago

That fixes the nag for when the .maintenance file is not cleaned up before its ten minute expiration.

comment:4 @ryan5 years ago

The .maintenance file expires after 10 minutes. Fixing the nag for that is probably as good as we're getting for 3.0. The .maintenance file "should" be deleted for all failure cases. Could you provide output for a failed upgrade so we can narrow down where cleanup may be missing?

comment:5 @bonjurkes5 years ago

Actually, i didn't wait for 10 mins .maintenance file get deleted if there is a failed update. Because if an update fails while i am performing it, i don't wait 10 minutes to login back to wp-admin. I just click back button to write ftp info or to try updating again, so i have to delete .maintenance file manually each time.

But when i click back button it shows "maintenance information".

comment:6 @ocean905 years ago

'Could you provide output for a failed upgrade so we can narrow down where cleanup may be missing?'

comment:7 @nacin5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Please re-open with additional steps to reproduce.

comment:8 @mrmist5 years ago

There have been quite a few support threads lately reporting sites stuck in maintenance mode after failed auto-updates. The message "an automatic WordPress update" failed. Please try again." remains even after a successful subsequent manual update...

Note: See TracTickets for help on using tickets.