WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13741 closed defect (bug) (fixed)

Plugin Installation not working

Reported by: slaith Owned by: dd32
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:

Description

Whenever I try to install a plugin from within Wordpress admin interface, it says Plugin install failed. "Could not Create Directory. /". Now I understand how this might be a problem since / directory cannot be created. I looked in wp-config, and many other sources, could not find anything wrong. ABSPATH registers correctly, but this problem is still there

Attachments (1)

Screenshot-1.jpg (90.4 KB) - added by slaith 4 years ago.
ScreenShot OF the Error

Download all attachments as: .zip

Change History (7)

slaith4 years ago

ScreenShot OF the Error

comment:1 dd324 years ago

  • Component changed from Plugins to Upgrade/Install
  • Keywords reporter-feedback added
  • Milestone changed from Unassigned to Future Release
  • Owner changed from westi to dd32
  • Priority changed from high to normal
  • Severity changed from major to normal

Did it work previously on this host?

Do you have to enter your FTP Credentials?

Do you have a 2.9.2 installation on the same host in the same style setup you can test?

If FTP, When you connect by FTP, what are the paths you see? Is WordPress installed in "/" when you connect by FTP, or something else such as /public_html/somehost.com/<WordPress files>

What path is ABSPATH set to?

Setting to Future Release pending confirmation of what the problem is.

comment:2 sivel4 years ago

  • Cc matt@… added

Someone experienced this problem the other day and came to the #wordpress irc channel. The end result was that they did not have a directory called wp-content/upgrade

Creating this directory manually and making it writable to the webserver user resolved the issue.

comment:3 dd324 years ago

The end result was that they did not have a directory called wp-content/upgrade

Creating this directory manually and making it writable to the webserver user resolved the issue.

Hm, That folder should be auto-created in all cases if it doesnt exist, I'll run a few tests to make sure thats still happening in edge-case environments shortly.

comment:4 slaith4 years ago

Done. There was no folder called upgrade. I made one and everything seems fine. Thanks Sivel. Also just for info, I wasn't asked for FTP credentials, ever, and this is a new install. Perhaps you should ship the folder in the distribution itself, instead of having it auto-created? Just a suggestion

comment:5 dd324 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15156]) Do not check to see if parents of folders outside of the Destination folder exist within the Archive extractors, unzip_file() will take care of that area. Fixes #13741

comment:6 dd324 years ago

  • Milestone changed from Future Release to 3.0

...Cant fix something in the future...

Note: See TracTickets for help on using tickets.