Make WordPress Core

Opened 5 years ago

Closed 11 months ago

#13767 closed enhancement (fixed)

Custom background uploader doesn't highlight max upload size

Reported by: Denis-de-Bernardy Owned by:
Milestone: 4.1 Priority: normal
Severity: normal Version: 3.0
Component: Customize Keywords: ux-feedback
Focuses: Cc:


When uploading a file from the custom background handler, you cannot tell in advance if it'll succeed or not if the file is too large. WP should advertise the max size, and the available space where relevant (see also #13765).

Change History (8)

#1 @ocean90
5 years ago

  • Keywords multisite removed
  • Milestone changed from 3.0 to 3.1
  • Type changed from defect (bug) to enhancement

To handle error messages better we need a bigger change for custom background (and custom header, see #13720). We should do this in 3.1.

#2 @nacin
5 years ago

  • Milestone changed from Awaiting Triage to Future Release

#3 @nacin
22 months ago

  • Component changed from Template to Appearance

Hmm. I don't know if I really care about this. Or, if necessary, it might be good if we just let the media manager do its thing and skip the idea of a direct type="file" input.

#4 @ocean90
19 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22148.

#5 @SergeyBiryukov
19 months ago

  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

This ticket is not about Customizer, so I guess #22148 won't handle this (not until #25569 happens).

#6 @ocean90
19 months ago

Oh, you're right. Now the comment by nacin makes sense. I think we should ditch the type="file" input then.

Last edited 13 months ago by ocean90 (previous) (diff)

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.

11 months ago

#8 @celloexpressions
11 months ago

  • Milestone changed from Awaiting Review to 4.1
  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed by [30309], and [30459].

Note: See TracTickets for help on using tickets.