WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 months ago

#13768 closed defect (bug) (duplicate)

Sub site with default theme missing will show blank pages

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Multisite Keywords:
Focuses: Cc:

Description

when creating a new site, it is possible to end up with a blank screen. reproduce:

  1. install a new theme
  2. in the multisite options, disable twentyten and the default theme for all sites
  3. create a new site

on my instance, the new site will be using the default theme. (note: this might be due to the fact that I've a custom theme folder without twentyten.)

Change History (7)

comment:1 @ocean905 years ago

The you should define a new WP_DEFAULT_THEME. See also #13743 and http://codex.wordpress.org/Super_Admin_Themes_SubPanel#Default_Theme

comment:2 @Denis-de-Bernardy5 years ago

agreed, but that doesn't mean WP should serve a blank page when the two themes are disabled.

comment:4 in reply to: ↑ description @wpmuguru5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Replying to Denis-de-Bernardy:

(note: this might be due to the fact that I've a custom theme folder without twentyten.)

That would be it. If you remove TwentyTen then you need to define a new default theme with WP_DEFAULT_THEME.

Disabling a theme in the Network Themes page does not prevent that theme being used by a site. It only prevents the theme being listed in the available themes list when selecting a new/different theme.

comment:5 @ocean905 years ago

  • Milestone 3.0 deleted

comment:6 @jorisw5 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from blank screen when creating a new site to Sub site with default theme missing will show blank pages
  • Version 3.0 deleted

Four years later I ran into this problem myself, and I had never heard of WP_DEFAULT_THEME . This constant isn't mentioned on the Create A Network Codex wiki page. This support forum thread eventually led me to the solution, i.e. to go into the sub site and (re)select the present theme: https://wordpress.org/support/topic/multi-site-subdomain-site-displays-blank-page?replies=8

I believe that this is still a bug, in that it is unexpected behaviour that your sub site will simply crash if you are not able to guess that if you remove the default theme, you need to set WP_DEFAULT_THEME. I believe that WordPress should at least display a sensible error like "Cannot load default theme. Please specify one or select one in the Appearance section".

comment:7 @SergeyBiryukov5 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #21931.

Note: See TracTickets for help on using tickets.