WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#13789 closed feature request (duplicate)

Hierarchical taxonomy UI is a text input on media files

Reported by: sillybean Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Media Keywords:
Focuses: Cc:

Description

I just tried applying a hierarchical custom taxonomy to media files as well as posts. It does appear in the upload and edit screens, but it's a text input (just like a non-hierarchical taxonomy) instead of a set of checkboxes.

Change History (3)

comment:1 @c3mdigital5 years ago

I tried doing the same thing by registering a taxonomy to the "attachment" post type and was not able to get a ui only a meta box under the file URL box. This is code I used to register the taxonomy:

register_taxonomy('media-type',array('attachment'), array(
    'hierarchical' => true,
    'labels' => $labels,
    'show_ui' => true,
    'query_var' => true,
    'rewrite' => array( 'slug' => 'media-type' ),
  ));

comment:2 @nacin5 years ago

  • Component changed from Taxonomy to Media
  • Milestone changed from Awaiting Review to Future Release
  • Type changed from defect (bug) to feature request

I think there's a plugin for this called Media Tags.

http://wordpress.org/extend/plugins/media-tags/

Beyond that, this sounds like a media feature request.

comment:3 @nacin3 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21391.

Note: See TracTickets for help on using tickets.