WordPress.org

Make WordPress Core

Opened 16 years ago

Closed 16 years ago

#1379 closed defect (bug) (worksforme)

I upgraded to WP 1.5.1 and now I get this "The requested theme does not exist."

Reported by: anonymousbugger Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Administration Keywords:
Focuses: Cc:

Description

From the dashboard whenever I click on Theme Editor I get a blank white page that says "The requested theme does not exist." My domain is www.getinmyhead.net, I started a new database for www.getinmyhead.net/pokerblog and uploaded 1.5.1 to that subdomain and it is giving the same error. Otherwise everything else seems to work just fine.

Change History (6)

#1 @anonymousbugger
16 years ago

  • Patch set to No

#3 @anonymousbugger
16 years ago

I can't reproduce consistently, but changing theme names from the wp-editor starts to break things it would seem. This does not happen with wp-default, but does happen with zen-minimalist. I cannot see why just yet. ~Podz

edited on: 05-20-05 09:34

#4 @carthik
16 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

#5 @Kelly64
16 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm encountering the same problem with WordPress 1.5.1.3 with all available themes including the default and classic. This started occuring after I added a few new themes: Clasikue, Ensellitis, and a customized version of Ensellitis.

Since it appears that others are having problems replicating the difficulty, I decided to dig a bit deeper. I altered theme-editor.php to dump the values of $theme and the contents of the $themes array at the point where the "die" takes place thusly:

if ( ! isset($themes[$theme]) )
{
        echo 'Theme= ',$theme,'<br />';
        foreach ($themes as $a_theme) {
                echo $a_theme['Name'],"<br />";
        }
        die(__('The requested theme does not exist.'));
}

I get the following results:

Theme= Mandrake
Clasikue
WordPress Classic
WordPress Default
Ensellitis New Theme
Customized Ensellitis
The requested theme does not exist.

I will admit to some confusion regarding the use of isset with an array of arrays, but the value of $theme (Mandrake) doesn't seem right to me at all. Some combination of weirdness in my configuration (and others) might be causing the $theme variable to become corrupt?

#6 @matt
16 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

PRobably a permissions issue.

Note: See TracTickets for help on using tickets.