WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 3 years ago

#13792 reopened defect (bug)

Invalid reply link from comment admin when comment nested level > max

Reported by: archon810 Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version: 2.9.2
Component: Comments Keywords: needs-patch ux-feedback
Focuses: Cc:

Description

I have a blog with nested comments enabled, max depth of 4. When the last level comment is posted, it no longer contains a Reply link.

However, in the Comment admin, the Reply link is still present. If used, this new reply will show up at the very bottom of the comment list once posted (even if other newer regular comments are entered, this new reply will still show up at the very bottom).

The bug is, basically, that Comment admin doesn't respect the max nested value.

Change History (11)

comment:1 archon8104 years ago

  • Cc admin@… added

comment:2 ocean904 years ago

You will see the reply link also when threaded comments are disabled. So it's not only for the threaded comments.

comment:3 markmcwilliams4 years ago

If for example you increase the max nested value, or turn on threaded comments, then all-of-a-sudden these comments would probably move into their respected place(s), which I do like the idea of actually. What about looking at maybe allowing authors, admins, and that being able to extend past the maximum if they're needing to answer something specific?

comment:4 ocean904 years ago

markmcwilliams, but then we must know if the theme support this.

comment:5 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

comment:6 archon8103 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Wait, nacin, why was this closed? It is most definitely still broken in 3.0.1. Replying to a comment from admin will be always possible, no matter whether the Reply depth has been reached. It is not a feature for admins - it's a bug. 100%.

comment:7 nacin3 years ago

  • Keywords close added

Because: "You will see the reply link also when threaded comments are disabled. So it's not only for the threaded comments."

comment:8 nacin3 years ago

  • Milestone set to Awaiting Review

comment:9 archon8103 years ago

In case of threaded comments disabled, this doesn't present a problem - you only have one methodology behind replying and that is your message becomes last. The reply button on every post then acts as 1 single giant reply button.

However, in the case of threaded comments with a reached limit, there should most certainly not be a reply button in the wp-admin for the same reason there shouldn't be any on the live site. The logic is exactly the same, whether it's on wp-admin or live post - I don't understand why there's such resistance to acknowledging it's a bug.

In the first paragraph, I expect my comment to show up where it does, while in the 2nd, I don't - it creates broken conversations because you, on the admin side, don't know that the thread limit has been reached and just use the Reply link blindly. Your reply, however, ends up who knows where all the way at the end, and that is buggy and unexpected behavior.

comment:10 nacin3 years ago

  • Keywords needs-patch ux-feedback added; close removed
  • Milestone changed from Awaiting Review to Future Release

Your persistence is appreciated. You've presented solid rationale, and I'm convinced.

Note: See TracTickets for help on using tickets.