WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#13795 closed defect (bug) (worksforme)

Setting HEADER_IMAGE to empty string causes Firefox to crash

Reported by: esmi Owned by: ocean90
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Themes Keywords: custom header
Focuses: Cc:

Description

Using define('HEADER_IMAGE', ) causes Firefox (XP/3.6.3) to hang on the Appearance/Header page initially without fully completing the page download. Returning to that page after accessing another Admin option is impossible and Firefox has to be killed via a commandline switch.

The issue can be replicated in TwentyTen by changing:

define( 'HEADER_IMAGE', '%s/images/headers/path.jpg' );

to:

define( 'HEADER_IMAGE', '' );

and also by simply commenting out the HEADER_IMAGE define. IE8/XP manages to remain stable but does display a js error on the second load of Appearance/Header.

Using nightly build: 3.0215172

Confirmed by second user using 3.0-RC2

Mass plugin deactivation had no effect.

Change History (3)

comment:1 @ocean905 years ago

  • Milestone changed from Unassigned to 3.0
  • Owner set to ocean90
  • Status changed from new to reviewing

What is the js error? I cannot reproduce it. The header image doesn't use any javascript, only for the header text color javascript is needed.

comment:2 @ocean905 years ago

Can you set WP_DEBUG = true and check, if there are some PHP messages?

comment:3 @westi5 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from reviewing to closed

I cannot reproduce this and the empty string is the default used if no-one has supplied the define.

The define is only checked in two places - Once for diplaying of a section of the admin page and once for the default in getting the header which uses the empty string as a default.

Closing as this works fine for me.

Note: See TracTickets for help on using tickets.