WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13808 closed defect (bug) (worksforme)

Changing screen options results in bad (blank) redirect

Reported by: mitchoyoshitaka Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Administration Keywords:
Focuses: Cc:

Description

  1. Go to edit posts/pages screen.
  2. Change the screen options and change the "show on screen" number and save.
  3. For me, it goes to a blank page.

Digging around, it looks like it's properly saving the option via set_screen_options(), but that wp_get_referer() at the end of set_screen_options() is returning an empty string, hence the failed redirect?

Change History (4)

comment:1 @mitchoyoshitaka5 years ago

  • Milestone set to 3.0

comment:2 follow-up: @nacin5 years ago

Mitcho, I can't reproduce this. Can you insert some debug code into wp_get_referer() and see why it's empty?

comment:3 in reply to: ↑ 2 @mitchoyoshitaka5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to nacin:

Mitcho, I can't reproduce this. Can you insert some debug code into wp_get_referer() and see why it's empty?

Hmm, this is disconcerting. I started added debug code, it seemed to be printing the referer fine; then removed the debug code, and it works...

So nevermind, then. Thanks Nacin.

comment:4 @nacin5 years ago

  • Milestone 3.0 deleted

No problem mitcho.

Note: See TracTickets for help on using tickets.