WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#13811 closed defect (bug) (invalid)

WordPress 2.9.2 is available! Please update now. - Failing to update

Reported by: sgaffili Owned by: dd32
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

I've tried this a few times now and keep getting the same error. Below is the log. I'm needing to upgrade from Wordpress 2.8.4.

Downloading update from http://wordpress.org/wordpress-2.9.2.zip.
Unpacking the update.
Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
Installation Failed

I'm running this blog on HostGator. I'm needing to move this blog, still on HostGator, but to a different account and Name Servers. So before I do I want to make sure it's up to date. I have a couple weeks before I'm up against the wall on this.

I've used both Firefox 3.5.9 and IE Version 8.0.6001.18702 with the same results.

I'm using XP Pro for an OS.

Change History (2)

#1 @ocean90
9 years ago

  • Milestone Unassigned deleted
  • Priority changed from high to normal
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from new to closed

Please try an manuel upgrade. This could be fixed with 2.9 and/or 3.0.
You can test it easy:

  • upgrade manually to 2.9.2
  • change the $wp_version in version.php to 2.8
  • try the automatic update again
  • if it doesn't work you can try the same with 3.0


Info: The 2.8 branch will not be supported. So closing this as invalid. If you have still problem you can use the WordPress Support Forums or if you think it's really a bug you can re-open.

#2 @dd32
9 years ago

Please open a new ticket if after a manual upgrade, you still experience problems.

That error message "PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature" usually indicates a incomplete download of the zip file, usually caused by the HTTP class not working properly on your host, Later versions have fixed bugs there so that shouldnt happen..

Note: See TracTickets for help on using tickets.