WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#13813 closed defect (bug) (wontfix)

Author permalink includes static text

Reported by: lonelicloud Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Permalinks Keywords: 2nd-opinion close
Focuses: Cc:

Description

In multisite mode, the author permalink is NOT correct when using post permalink like /posts/%postname%/. In this case, author permalink is generated as

http://yourdomainname.tld/blog/posts/author/authorname

The base word POSTS is added to this, not like before. Should it be

http://yourdomainname.tld/blog/author/authorname

Please check it! Maybe also accur in single site mode.

It's my first ticket. I'm not sure wether it meets the requirements. But the problem is real.

Change History (9)

comment:1 lonelicloud4 years ago

  • Summary changed from Author permalink in WP3.0 multisite mode (maybe in single site mode) to Author permalink in WP3.0 multisite mode (maybe in single site mode too)

comment:2 lonelicloud4 years ago

  • Severity changed from normal to critical

comment:3 follow-up: duck_4 years ago

  • Keywords 2nd-opinion close added; permalink author removed
  • Priority changed from high to normal
  • Severity changed from critical to normal
  • Summary changed from Author permalink in WP3.0 multisite mode (maybe in single site mode too) to Author permalink includes static text
  • Version changed from 3.0 to 2.7

I believe this is the expected behaviour, experiencing it back to 2.7 (not looked at older versions) and when using one of the default permalink settings (/archives/%post_id%).

comment:4 follow-up: nacin4 years ago

This does make sense in the sense that you're looking at "archives" or "posts" (using the two examples) written by a certain author.

We wouldn't change the way the permalinks are created because it would break existing links. But if you're using author pages for more than just posts, such as a custom post type, then you should change the rewrites via a plugin.

comment:5 in reply to: ↑ 3 lonelicloud4 years ago

Replying to duck_:

I believe this is the expected behaviour, experiencing it back to 2.7 (not looked at older versions) and when using one of the default permalink settings (/archives/%post_id%).

OK, thank you! I began to use wordpress from version 2.8.4, so I didn't know the history.
The ticket was posted because it would cause link-not-found error when user upgrading from single site wordpress to multisite mode. Maybe we are not view this problem at the same way.

comment:6 in reply to: ↑ 4 lonelicloud4 years ago

Replying to nacin:

This does make sense in the sense that you're looking at "archives" or "posts" (using the two examples) written by a certain author.

We wouldn't change the way the permalinks are created because it would break existing links. But if you're using author pages for more than just posts, such as a custom post type, then you should change the rewrites via a plugin.

Thank you, nacin! Your explanation does make sense for me. Because WE can't provide a perfect solution, so we have to lose something for something more valuable.

comment:7 follow-up: nacin4 years ago

The ticket was posted because it would cause link-not-found error when user upgrading from single site wordpress to multisite mode.

That's probably coming out of us prepending /blog to the main site's permalinks, which is why we warn the administrator about that when creating a network via Tools > Network.

comment:8 in reply to: ↑ 7 lonelicloud4 years ago

Replying to nacin:

The ticket was posted because it would cause link-not-found error when user upgrading from single site wordpress to multisite mode.

That's probably coming out of us prepending /blog to the main site's permalinks, which is why we warn the administrator about that when creating a network via Tools > Network.

Really thank you nacin! I noticed the problem and solved it on my blog site. I upgraded my blog site from version 2.9.2 to 3.0 RC1 then 3.0 RC2, and I noticed that the author permalink changed from domain.tld/author/xxx to domain.tld/blog/articles/author/xxx but not domain.tld/blog/author/xxx, where articles is my static text base for my post's permalink. Then I raised this ticket to inform you developers. It's not really a big problem for me as I can make a 301 redirection from old link to the new one. I THOUGHT it's a defect but it's NOT, it's just a necessary adjustment.
Thank you for your warmhearted concern again!

comment:9 nacin4 years ago

  • Milestone 3.0 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

We hope to tackle /blog in 3.1 by implementing global permalink collision detection. That's its current purpose, to prevent the root site links from conflicting with subdirectory links. If you use subdomains, you won't see this.

There is also a plugin or two that can remove it if necessary.

Note: See TracTickets for help on using tickets.