WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 16 months ago

#13826 closed defect (bug) (fixed)

Enter New Custom Field Margin Error

Reported by: dgrahn Owned by:
Milestone: 3.5 Priority: normal
Severity: minor Version: 3.0
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

The "Enter New" custom field button butts up against the left border.

Can be fixed with this css

#enternew {margin: 8px 0 8px 10px;}

Attachments (1)

13826.patch (335 bytes) - added by ocean90 4 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 dgrahn4 years ago

  • Keywords has-patch added; custom field removed

comment:2 dgrahn4 years ago

  • Owner dgrahn deleted
  • Status changed from new to assigned

ocean904 years ago

comment:3 ocean904 years ago

  • Component changed from Formatting to UI
  • Milestone changed from Unassigned to 3.0

Instead of margin we can use display: block. With this the Cancel and Add New link are correctly positioned.

comment:4 nacin4 years ago

  • Milestone changed from 3.0 to Future Release

I don't see this on Firefox 3.6.3, Chrome 5, both Mac. I asked johnjamesjacoby and he can't reproduce this on Windows, after trying Firefox 3.6.3, IE8, and IE7.

Punting, because this is trivial and apparently quite the edge case.

Also, screenshots would really help.

comment:5 TECannon4 years ago

I wasn't able to replicate a display error, but it does look like the js toggle adds the inline style "display:inline" when toggling off of "display:none". (Which means the patch would not work once the Add New | Cancel had been toggled.)

comment:6 TECannon4 years ago

OK. Scratch my previous comment. The patch works (at least in FF Windows).

I got the bug to replicate when the box is wider than about 950px.

comment:7 hakre4 years ago

Commit & close?

comment:8 helen16 months ago

  • Component changed from UI to Administration
  • Milestone changed from Future Release to 3.5
  • Resolution set to fixed
  • Status changed from assigned to closed

Seems like it was fixed, set to inline-block in [21955].

Note: See TracTickets for help on using tickets.