WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 17 months ago

#13835 closed feature request (wontfix)

XML-RPC API should return commentmeta values

Reported by: djr Owned by: josephscott
Milestone: Priority: normal
Severity: normal Version: 2.9
Component: XML-RPC Keywords: needs-patch needs-unit-tests
Focuses: Cc:

Description

This ticket is a follow up on my Twitter and subsequently email conversation with Joseph Scott (josephscott) about the new commentmeta table in WordPress 2.9 and the XML-RPC API. We use the plugin Feature Comments (http://wpprogrammer.com/feature-comments-wordpress-plugin/) for hiding or featuring certain comments. The plugin stores either a value of 'Buried' or 'Featured' in the commentmeta table and uses these values to append a css class to comment_class.

I'd love to retrieve these commentmeta values (buried/features) through the XML-RPC API (which we use) with wp.GetComment or wp.GetComments, so we're able to programmatically hide or feature these comments in our own iPhone app.

Please note this is a specific example, but my request should I no way be seen as a private request. I think the commentmeta in 2.9 was a great addition for stuff like Twitter usernames, mood, gender, and so forth. I hope we're able to retrieve these values programmaticaly through the API as well.

Attachments (1)

getcommentmeta.diff (462 bytes) - added by nprasath002 7 years ago.

Download all attachments as: .zip

Change History (20)

#1 @djr
8 years ago

  • Severity changed from normal to minor

#2 @djr
8 years ago

  • Version set to 2.9.2

#3 @nacin
8 years ago

  • Keywords needs-patch added; xml-rpc commentmeta api removed
  • Milestone changed from Unassigned to Future Release
  • Version changed from 2.9.2 to 2.9

#4 @nprasath002
7 years ago

  • Cc n.prasath.002@… added
  • Keywords has-patch added; needs-patch removed

#5 @ericmann
7 years ago

  • Keywords needs-patch added; has-patch removed

That patch won't work.

get_comment_meta() takes in more than just the comment id. You also need to specify the key you're retrieving. Here's the full function from the source:

function get_comment_meta($comment_id, $key, $single = false) {
    return get_metadata('comment', $comment_id, $key, $single);
}

$single is optional (and not needed in this case), but $key is not. At the very minimum, you'd have to loop through and get all the keys so you could retrieve all the comment meta.

#6 @ericmann
7 years ago

  • Keywords has-patch needs-testing added; needs-patch removed
  • Version changed from 2.9 to 3.1

Scratch that, apparently you can leave $key blank to have the function return everything. Looks good.

#7 follow-up: @aaroncampbell
7 years ago

  • Version changed from 3.1 to 2.9

Please don't change the version on the ticket. The version is used to track the version when the error first occurred.

#8 in reply to: ↑ 7 ; follow-up: @ericmann
7 years ago

Replying to aaroncampbell:

The version is used to track the version when the error first occurred.

Considering this is a feature request and not a bug fix, should we be patching and reporting against trunk? It's not an error ... but a requested API enhancement for a feature introduced in 2.9.

#9 in reply to: ↑ 8 @nacin
7 years ago

Replying to ericmann:

Considering this is a feature request and not a bug fix, should we be patching and reporting against trunk?

Yes, always patch against trunk.

It's not an error ... but a requested API enhancement for a feature introduced in 2.9.

The version field is for the earliest applicable version of a report. Generally for bugs, but works for enhancements just fine too. Version 2.9 is appropriate here as that's when commentmeta came into play.

#10 @nprasath002
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

THe documentation for get_comment_meta is not complete as the key value and the boolean is optional. i created a ticket for that here http://core.trac.wordpress.org/ticket/16965

Also i normally test with a java client and print to see whether i,m getting the expected results should i removed needs testing??

P.S - i,m nt getting any updates about this ticket via email. how can i do that

#11 @nprasath002
7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#12 @dd32
7 years ago

P.S - i,m nt getting any updates about this ticket via email. how can i do that

Ensure your email is listed in the preferences and check the CC box when making a reply.

#13 @chriscct7
4 years ago

  • Keywords needs-patch added; has-patch needs-testing removed

Patch on this needs to be updated per comments, but not a refresh so needs patch I guess.

#14 @chriscct7
3 years ago

  • Keywords needs-unit-tests added
  • Priority changed from low to normal
  • Severity changed from minor to normal

#15 @swissspidy
17 months ago

See also #35991 for term meta.

With the REST API now in core, are these new features to XML-RPC still relevant?

#16 @redsweater
17 months ago

Speaking only as one significant user of the XML-RPC API, these enhancements are not useful to me. Generally speaking I would be happy to see XML-RPC development slow or cease in favor of the REST API, which I hope to move to at some point.

#17 @dd32
17 months ago

I would be happy to see XML-RPC development slow or cease in favor of the REST API, which I hope to move to at some point.

I would be happy to see that happen; XML-RPC should be maintained and bugs fixed obviously - but I'm not sure adding new features to an API which few people would choose to use over a REST API - even if only just for the larger number of API clients written.

#18 @SergeyBiryukov
17 months ago

  • Summary changed from XLM-RPC API should return commentmeta values to XML-RPC API should return commentmeta values

#19 @swissspidy
17 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

Given the lack of traction, the recent feedback, and the shift to the REST API, I'm closing this one as a wontfix. Could also be a maybelater, but I doubt that it will suddenly become relevant.

Note: See TracTickets for help on using tickets.