WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#13848 closed defect (bug) (worksforme)

Title on all New [Post Type] screens is "New Post"

Reported by: caesarsgrunt Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

In 3.0-RC2-15182 the title of the New [Post Type] pages is always New Post. The correct title was shown in a (much) earlier build; seems this is a regression.

Attachments (1)

Screen shot 2010-06-11 at 10.35.03.png (30.4 KB) - added by caesarsgrunt 11 years ago.
Should read "Add New Book"

Download all attachments as: .zip

Change History (7)

@caesarsgrunt
11 years ago

Should read "Add New Book"

#1 @ocean90
11 years ago

  • Milestone Unassigned deleted
  • Resolution set to worksforme
  • Status changed from new to closed

You need to register the 'add_new_item' label.

'labels' => array(
  'add_new' => 'this is the menu text',
  'add_new_item' => 'This is the title'
)

#3 @caesarsgrunt
11 years ago

Ah; seems the API has changed since I last tested this feature. Sorry for the false bug and thanks for the explanation.

#4 @nacin
11 years ago

Yep, we rearranged a few things for maximum i18n compatibility.

#5 @caesarsgrunt
11 years ago

Might be best, though, if add_new_item fell back to "Add New singular_name" if add_new_item was unspecified. But it's too late to make any change now, I guess.

#6 @nacin
11 years ago

We can't for i18n reasons - #12968

Note: See TracTickets for help on using tickets.