WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#13865 closed defect (bug) (fixed)

Fix sprintf placeholders in string in wp-inc/load.php

Reported by: demetris Owned by: westi
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: I18N Keywords: has-patch dev-reviewed i18n-change commit regression
Focuses: Cc:

Description

See attached patch.

This may need to go into 3.0.

Attachments (1)

t13865-sprintf-placeholders.diff (978 bytes) - added by demetris 11 years ago.
Fixing sprintf placeholders

Download all attachments as: .zip

Change History (5)

@demetris
11 years ago

Fixing sprintf placeholders

#1 @westi
11 years ago

  • Component changed from General to i18n
  • Keywords dev-reviewed added
  • Owner set to westi
  • Status changed from new to accepted

This looks like an honest mistake - surprised no one caught it yet!

I guess these strings have to be manually translated so us changing them doesn't directly affect translators?

#2 @demetris
11 years ago

As far as I understand, the non gettexted strings are handled automatically by the build system that is used by the various locale.wordpress.org sites.

(You tell the build system which WP tag/branch to use with which locale tag/branch. It then puts together the package, making the replacements of non-gettexted strings automatically and saving the changed files as UTF-8 without a BOM.)

So, on the one hand, translations will not be affected.

On the other hand, translations will still have a string that gives no information.

#3 @nacin
11 years ago

  • Keywords i18n-change commit regression added

Looks like I screwed this up in [12732]. Committing.

#4 @nacin
11 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [15240]) Fix two sprintf placeholders in a WP_I18N string. props demetris, fixes #13865.

Note: See TracTickets for help on using tickets.