WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#13868 closed defect (bug) (fixed)

jQuery UI 1.7.3

Reported by: nacin Owned by:
Milestone: 3.0 Priority: high
Severity: normal Version:
Component: JavaScript Keywords: has-patch commit
Focuses: Cc:
PR Number:

Description

1.7.3 is a maintenance release with three changes, to make the 1.7 branch compatible with the jQuery 1.4 branch.

http://jqueryui.com/docs/Changelog/1.7.3

Strongly suggesting we push this in 3.0 if we can be sure these are internal issues that won't break anything we're doing.

(Cross referencing #12863, which would be getting UI 1.8 into 3.1.)

Attachments (1)

13868.001.diff (196.1 KB) - added by aaroncampbell 9 years ago.

Download all attachments as: .zip

Change History (6)

#1 @aaroncampbell
9 years ago

I'm all for getting this into 3.0 as well. Very few changes, and they fix some really annoying issues.

#2 @aaroncampbell
9 years ago

  • Keywords has-patch added; needs-patch removed

#3 @nacin
9 years ago

  • Keywords commit added; dev-feedback removed

We think we're safe here. Two changes are in tabs, which we don't use in core, and the third looks okay. koopersmith located the source here. http://code.google.com/p/jquery-ui/source/detail?r=3977

Favoring commit.

#4 @ocean90
9 years ago

+1
The IE8 Bug could be annoying for us or plugin devs.

#5 @automattor
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15243]) Update jQuery UI to 1.7.3 (small maintenance update with three little changes). props aaroncampbell. fixes #13868

Note: See TracTickets for help on using tickets.