WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13890 closed defect (bug) (fixed)

IE8 wrong display

Reported by: pavelevap Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: UI Keywords: has-patch regression
Focuses: Cc:

Description

Latest trunk, IE8 (Firefox works well), see attached screenshot.

1) There are missing space between boxes (see red lines on attached screenshot).

2) Title field - inserting letters like g,q,p, etc. leads to hiding lower parts of these letters (see red circle on attached screenshot).

Attachments (2)

IE8_display.png (36.1 KB) - added by pavelevap 5 years ago.
13890.patch (360 bytes) - added by ocean90 5 years ago.
Line height IE 8 fix

Download all attachments as: .zip

Change History (12)

@pavelevap5 years ago

comment:1 @ocean905 years ago

  • Component changed from General to UI
  • Keywords needs-patch added
  • Version set to 3.0

I can only reproduce the 2. point. I'm working on a patch.

@ocean905 years ago

Line height IE 8 fix

comment:2 @ocean905 years ago

  • Keywords has-patch added; needs-patch removed

13890.patch should fix the bug in IE 8. The line-height was 15px, inherited from global.css, IE...
pavelevap: Any plugins activated? Already cleared the chache?

comment:3 @pavelevap5 years ago

All plugins deactivated, cache cleared. Problem persists...

comment:4 @wpmuguru5 years ago

You have to turn on dev scripts to see the effect of the patch

define('SCRIPT_DEBUG', true);

(I don't have IE8 so I can't test.

comment:5 @ocean905 years ago

Related to the missing space between boxes: #13464

comment:6 @nacin5 years ago

  • Keywords regression added

Caused by r12678.

comment:7 @nacin5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15255]) Fix IE8 line-height of title input. props ocean90, fixes #13890.

comment:8 follow-up: @pavelevap5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

There is also first problem. Cache was cleared once again (temp files and cookies).

Missing space between boxes is only between Post Editor Area, Excerpt, Trackbacks and Custom fields. Then space is visible (Comments, Slug, Author). The same problem is for Pages (only between Page Editor Area and Custom Fields box).

And there is another Javascript problem: Changing columns in Screen options from 2 to 1 = all boxes are in one column, space is visible everywhere. Changing back to 2 columns - all boxes stay at their position (supposed behaviour are boxes Publish, Categories, etc. in right column).

Another playing with this problem: Missing space between boxes appears only in the left column where there are boxes in right column. So when there is only one column, then spaces are visible. When there are two columns then until right column ends, no space between boxes in the left column is visible...

comment:9 in reply to: ↑ 8 @nacin5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to pavelevap:

There is also first problem. Cache was cleared once again (temp files and cookies).

Missing space between boxes is only between Post Editor Area, Excerpt, Trackbacks and Custom fields. Then space is visible (Comments, Slug, Author). The same problem is for Pages (only between Page Editor Area and Custom Fields box).

Please see #13464. You may re-open that one with steps to reproduce, a patch, or additional feedback, in a future milestone (> 3.0).

And there is another Javascript problem: Changing columns in Screen options from 2 to 1 = all boxes are in one column, space is visible everywhere. Changing back to 2 columns - all boxes stay at their position (supposed behaviour are boxes Publish, Categories, etc. in right column).

See: #13476.

Another playing with this problem: Missing space between boxes appears only in the left column where there are boxes in right column. So when there is only one column, then spaces are visible. When there are two columns then until right column ends, no space between boxes in the left column is visible...

See #13464.

Re-closing.

comment:10 @pavelevap5 years ago

OK, thank you. I did not notice another ticket about switching columns...

Note: See TracTickets for help on using tickets.