WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#13896 closed defect (bug) (invalid)

js load error in RC3 on wamp

Reported by: mati1000 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: JavaScript Keywords: reporter-feedback
Focuses: Cc:

Description

sorry of my bad English.

I have upgrade my local wordpress (running on "wamp") to RC3

version and I cant use more the admin panel Because of a js error in:

load-scripts.php?c=1&load=hoverIntent,common,jquery-color,wp-ajax-response,wp-lists,jquery-ui-core,jquery-ui-resizable,admin-comments,jquery-ui-sortable,postbox,dashboard,thickbox,plugin-install,media-upload&ver=1c33e12a06a28402104d18bdc95ada53,
line 1 char 300

I try it in IE/FF and in buth the javascript not working

Change History (18)

comment:1 @paperreduction5 years ago

Having same issue on linux box (though i don't think the OS has anything to do with it). Error I'm getting is "this._mouseInit is not a function".

I'll try to switch to the dev version to get more info, but maybe someone will beat me to it.

comment:2 follow-up: @nacin5 years ago

  • Keywords reporter-feedback added; js error windows removed

Please disable all of your plugins.

comment:3 in reply to: ↑ 2 @mati10005 years ago

before I open the ticket I install a new clear wordpress installation - with the same error

Replying to nacin:

Please disable all of your plugins.

comment:4 follow-up: @nacin5 years ago

Okay, can you add define('SCRIPT_DEBUG', true); to wp-config and see if that takes care of it?

comment:5 @nacin5 years ago

Is this on every page? What page are you seeing this? I'm having trouble locating which page loads all of those scripts.

comment:6 follow-up: @ocean905 years ago

It's the dashboard page.
My output:

<script type='text/javascript' src='http://localhost/wp/wp-admin/load-scripts.php?c=1&amp;load=hoverIntent,common,jquery-color,wp-ajax-response,wp-lists,jquery-ui-core,jquery-ui-resizable,admin-comments,jquery-ui-sortable,postbox,dashboard,thickbox,plugin-install,media-upload&amp;ver=1c33e12a06a28402104d18bdc95ada53'></script>

mati1000, do you get mati1000 &amp; or & in your URL?

comment:7 @nacin5 years ago

Apparently my comment never went through on here.

It is indeed the dashboard page, specifically the JavaScript error is referring to an unbind call within a jQuery plugin called hoverIntent. We've used that plugin for quite a while, it is not modified from its original source, and I minified it again to find that it matched what was in trunk. So I'm not sure what's going on here. Having no problems in all the browsers I've tried, including FF 3.6.3.

comment:8 in reply to: ↑ 4 @mati10005 years ago

yes! I added and this takes care of it!

why?

Replying to nacin:

Okay, can you add define('SCRIPT_DEBUG', true); to wp-config and see if that takes care of it?

comment:9 in reply to: ↑ 6 @mati10005 years ago

I get &amp;

Replying to ocean90:

It's the dashboard page.
My output:

<script type='text/javascript' src='http://localhost/wp/wp-admin/load-scripts.php?c=1&amp;load=hoverIntent,common,jquery-color,wp-ajax-response,wp-lists,jquery-ui-core,jquery-ui-resizable,admin-comments,jquery-ui-sortable,postbox,dashboard,thickbox,plugin-install,media-upload&amp;ver=1c33e12a06a28402104d18bdc95ada53'></script>

mati1000, do you get mati1000 &amp; or & in your URL?

comment:10 @paperreduction5 years ago

@nacin, did the versions of jquery or jquery UI change? This issue seems to get crazier the more i've looked into it.

I found the same thing you did by switching to dev files. Thinking my files were corrupt i pulled down RC3 over SSH and unpacked on server. That still didn't fix it. I blew away the dbase did clean install and the error was gone!

After adding 4 pages (in the span of 2 minutes) the js error was back (I was watching my error counsel...). I verified the error in Safari as well.

I cleared the dbase again (dropped all tables), and again after install everything was fine. Plus I created all pages w/o issue. So I can't reproduce the problem consistently.

Can this somehow be dbase related? Being a js issue, that would seem to be really odd.

comment:11 @paperreduction5 years ago

SOLVED (for me at least):
Realizing the database played a roll in this, I got firebug running and started looking through everything...

The theme I'm using has jQuery UI defined inside! And it's not queued, and there's no is_admin check. I didn't catch it above because I was trying to get everything reloaded, and I was creating pages while doing this other stuff.

So, removing the include solved the issue for me, not sure if this is the same problem for others. But hopefully this helps. (Note jQuery UI 1.8.1 was being included)

comment:12 @ocean905 years ago

  • Keywords reporter-feedback removed
  • Milestone Unassigned deleted
  • Priority changed from high to normal
  • Resolution set to invalid
  • Status changed from new to closed

WordPress Backend doesn't support UI 1.8 yet, see also #12863. An !is_admin() check would be good.

comment:13 @mati10005 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I (ticket opener ) dont using UI 1.8.

I installed a new instalion of RC3 and the JS in admin panel have errors.

after I added: define('SCRIPT_DEBUG', true);

  • its work (with the dev version of jQuery).

maby the "minified" is bad.

comment:14 follow-up: @nacin5 years ago

  • Milestone set to Unassigned

I can confirm the minified works for me in Chrome 5, Firefox 3.6.3, etc.

Can you turn off script concatenation? define('CONCATENATE_SCRIPTS', false);. That will still print the minified scripts but not concatenate them. If you still see an error in hoverIntent, then we'll try something else.

comment:15 in reply to: ↑ 14 @mati10005 years ago

this help! I dont have errors.

Replying to nacin:

I can confirm the minified works for me in Chrome 5, Firefox 3.6.3, etc.

Can you turn off script concatenation? define('CONCATENATE_SCRIPTS', false);. That will still print the minified scripts but not concatenate them. If you still see an error in hoverIntent, then we'll try something else.

comment:16 @nacin5 years ago

I'm out of ideas then. Concatenating the same scripts should mean no difference.

Can you reproduce this in 2.9?

comment:17 @duck_5 years ago

  • Keywords reporter-feedback added

comment:18 @nacin5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.