WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 9 months ago

#13942 closed defect (bug) (fixed)

Logged-out notice in post edit page is easily missed

Reported by: RanYanivHartstein Owned by:
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.0
Component: Editor Keywords: ux-feedback has-patch
Focuses: Cc:

Description (last modified by lloydbudd)

When a user gets logged out during post editing, a small warning appears bellow the post editor, next to the word count. This warning states that changes will not be saved until user logs in again - but it's a small notice and is very easily missed.

Since this can be potentially catastrophic for users writing long posts while relying on auto-save, a bigger and more prominent notice probably makes more sense.

Repro

ENV: WP 3.0

This bug can be reproduced in WordPress 3.0 by opening two tabs – one tab with a blog’s Dashboard, and another tab with the same blog’s New Post page. In the Dashboard, click Logout, then switch to the New Post tab. Here, enter any text in the post’s title, then hit Tab to switch to the editor. This will trigger the permalink preview, which will in turn trigger the notice about being logged out: “ALERT: You are logged out! Could not save draft. Please log in again.”

Additional Details

The notice comes from wp-admin/admin-ajax.php, in line 36.

Currently behavior was introduced by #7630, where it was already noted "maybe something more obvious needed"

Attachments (3)

2010-06-17-13-58-42.png (71.6 KB) - added by RanYanivHartstein 4 years ago.
Screen shot of the notice displayed when user gets logged out while writing a post
admin-ajax.php.diff (699 bytes) - added by dangayle 4 years ago.
Added span with class "error" to highlight problem
2010-07-08.png (9.3 KB) - added by dangayle 4 years ago.
Screenshot of patched results

Download all attachments as: .zip

Change History (16)

RanYanivHartstein4 years ago

Screen shot of the notice displayed when user gets logged out while writing a post

comment:1 lloydbudd4 years ago

  • Description modified (diff)
  • Milestone changed from Unassigned to Future Release
  • Version set to 3.0

comment:2 lloydbudd4 years ago

  • Description modified (diff)

dangayle4 years ago

Added span with class "error" to highlight problem

dangayle4 years ago

Screenshot of patched results

comment:3 dangayle4 years ago

  • Cc dangayle added

comment:4 dangayle4 years ago

  • Keywords has-patch added

comment:5 RanYanivHartstein3 years ago

I feel the current patch does not fully address the original issue. The current notice, even with stronger colors, is too subtle and unobtrusive. I don't see any point in letting users continue writing after they are logged out - we are literally setting them up to lose all their work.

If it were me, I would want this notice to be as obvious as possible. It should literally make me stop what I'm doing and log out again, because otherwise I will almost certainly lose my work.

This is what happens when you are logged out of Google Docs: http://grab.by/7Rie

The whole screen is blackened and a notice appears telling you you can't do anything until you log back in.

comment:6 lloydbudd3 years ago

The current and proposed solutions also doesn't address people that are authoring in full screen mode.

comment:7 SergeyBiryukov2 years ago

  • Keywords changed from ux-feedback, has-patch to ux-feedback has-patch

Related: #20599

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

comment:8 mbijon2 years ago

  • Keywords 2nd-opinion added

I think I prefer the P2 UX to the one in the patch above. I noted that in #20599, but am closing that one as a duplicate of this.

My input from there:
A better UX for logged out posting is in the P2 theme. It opens a popup saying you're logged out and disables the form posting capability. Can we attempt a similar, more-obvious UX for both the editing page and distraction-free editor?

This bug and improved logged out notice are detailed better here by Daniel Bachhuber: http://danielbachhuber.com/2012/05/01/notify-when-logged-out/

comment:9 danielbachhuber2 years ago

  • Cc wordpress@… added

comment:10 mbijon2 years ago

  • Cc mike@… added

comment:11 ethitter19 months ago

  • Cc erick@… added

comment:12 MikeHansenMe9 months ago

  • Cc mdhansen@… added
  • Keywords close added

This problem has been addressed by the new heartbeat modal that shows when you get logged out during writing. In addition a local storage back up is saved to avoid the content loss. I did find a small related bug but will open a new ticket for it. Proposing close.

Version 0, edited 9 months ago by MikeHansenMe (next)

comment:13 DrewAPicture9 months ago

  • Keywords 2nd-opinion close removed
  • Milestone changed from Future Release to 3.6
  • Resolution set to fixed
  • Status changed from new to closed

Let's call this fixed as of [23692], see #23216.

Note: See TracTickets for help on using tickets.