Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#13985 closed defect (bug) (duplicate)

Save draft-button does not set post status to draft when post has no title or content

Reported by: eskapism Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: 2nd-opinion close
Focuses: Cc:


Save draft-button does not set post status to draft when post has no title or content.

Also "save_post" action is not called, making plugins like mine (http://wordpress.org/extend/plugins/simple-fields/) unable to save it's values.

But some things get saved: if you fill in custom fields or featured image, these are saved. Tags and categories, however, are not saved.

So if you fill in custom fields and then save, there are no way to get these back if you leave the edit page (unless accssing the db directly, of course). That can be confusing for users and they may feel that they have lost their content.

Finally, if clicking "save draft" or "publish" you get a message saying "Page published/updated. View page." but that link leads to a page not found error.

Expected result: if I click "save draft" or "publish" I except the post to change from auto-draft to draft. As a user I have made the choice to save the post, and it should not matter that I haven't entered a title or content. This can be the case when I have a template that supports some special case of page where for example only the featured image is shown.

Change History (2)

#1 @duck_
5 years ago

  • Keywords 2nd-opinion close added

The expected behaviour for trying to save a post with no title/content is to do nothing, but unfortunately the current message is wrong.

If I'm right about the behaviour, then:
Duplicate of #11082

#2 @nacin
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.