WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 14 months ago

#13993 closed defect (bug) (fixed)

Twenty Ten: twentyten or twenty-ten (update check failed)

Reported by: zeo Owned by: iandstewart
Milestone: WordPress.org Priority: normal
Severity: major Version: 3.0
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Twenty Ten theme update check failed because core repos using twentyten as directory name while theme repos using twenty-ten.

Since WordPress 3.0 already shipped Twenty Ten theme using directory name twentyten, there's only one smart and possible solution:
svn rename twenty-ten in theme repository to twentyten.

This way everyone that already download 3.0 can directly update the theme from admin panel.

Not sure the drawbacks on the theme repos side. URL change? Theme name change?

To reproduce:
In your current 3.0 installation, rename your current twentyten directory to twenty-ten. You'll get an update notification.

Change History (18)

comment:1 zeo4 years ago

Also, it would be best to make twenty ten external.

There's going to be serious issue not be able to keep up with one another (Twenty Ten in core repos and Twenty Ten in theme repos).

comment:2 follow-up: dd324 years ago

Also, it would be best to make twenty ten external.

That'll be happening at some point soon.

comment:3 dd324 years ago

  • Component changed from Themes to WordPress.org
  • Milestone changed from 3.0.1 to WordPress.org site

comment:4 in reply to: ↑ 2 zeo4 years ago

Replying to dd32:

That'll be happening at some point soon.

According to rboren during the time of 3.0 release, there are no plan to make it external. That's why the current copy in core repo is different from the one in themes repo.

I wonder how to make this external, since there's no branches in the themes repository only tags.

themes repo: http://themes.svn.wordpress.org/twenty-ten/
core repo: http://core.svn.wordpress.org/wp-content/themes/twentyten/

comment:5 nacin4 years ago

  • Keywords dev-feedback removed
  • Owner changed from josephscott to mdawaffe
  • Status changed from new to assigned

I don't have a problem not doing an external, just so long we keep them in sync every few weeks.

We do need to change twenty-ten to twentyten. That would have to go through mdawaffe I think.

comment:6 ryan4 years ago

Pinged Ian about changing it to twentyen

comment:7 dd324 years ago

That'll be happening at some point soon.

According to rboren during the time of 3.0 release, there are no plan to make it external.

I may've been mistaken there then :) - Having it in the core does make it a bit easier to update if need be, and given the non-svn-standard layout of the themes repo, it would make it a bit awkward to do an external.

comment:8 zeo4 years ago

  • Owner changed from mdawaffe to iandstewart

Since everyone here mostly use svn checkout and not update from Admin panel, the best way is all 2010 changes goes in the core first. This also reduce version bump in themes repository.

Do a weekly routine check if there's any changes then sync it to themes repository.

comment:9 josephscott4 years ago

As hinted at in the ticket, the source of the problem is a naming inconsistency in WP3.0. The directory name is themes/twentyten, but the name of the theme in style.css is "Twenty Ten", which would make the slug for it "twenty-ten". This is what the theme directory process did when it was uploaded, it created a "twenty-ten" slug, based on the name of the theme.

I'm going to attempt to hand tweak the theme directory item to get this to match enough so that the update logic catches it. For future themes (Twenty Eleven?) we need to be consistent with the directory & theme names.

comment:10 iandstewart4 years ago

We may have to change the theme name from "Twenty Ten" to "TwentyTen" in order to get this to work.

comment:11 pavelevap4 years ago

  • Cc pavelevap@… added

Hi, as a translator, I probably translate trunk version in GlotPress? But it should be also available translate version from themes directory. There can be long gap between WordPress versions, but changes in TwentyTen can be done. So, users will update and there will be untranslated strings...

comment:12 iandstewart4 years ago

We did indeed have to change the name. It's TwentyTen now.

comment:13 michaelh4 years ago

Confused here--should we see an update in Dashboard->Updates for TwentyTen or do we have to manually download the files to get to the latest update for this theme?

comment:14 zeo4 years ago

TwentyTen: http://wordpress.org/extend/themes/twentyten

So it's impossible to maintain the name "Twenty Ten" while having twentyten as a directory name in theme repository? I'm sure the guys that in charge of the theme repository could make an exception.

You do realize that a lot of changes that need to be made if this is final.

comment:15 josephscott4 years ago

I've been experimenting with different options, so far none of them have worked 100%. At this point I may have to hard code in an exception into the API for "Twenty Ten", which is completely lame. So in the future, please, please make theme names consistent.

comment:16 nacin4 years ago

  • Component changed from WordPress.org to Themes

comment:17 SergeyBiryukov16 months ago

  • Component changed from Themes to Bundled Theme

comment:18 lancewillett14 months ago

  • Priority changed from high to normal
  • Resolution set to fixed
  • Status changed from assigned to closed

This has been solved by Samuel Wood (aka Otto) -- now each time we submit a default theme he fixes it after the first upload.

Note: See TracTickets for help on using tickets.