Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#14005 closed defect (bug) (wontfix)

Twenty Ten theme: title and tagline lengths

Reported by: jrawle Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.0
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:


The new default theme, Twenty Ten, seems to assume a long title and short tagline. Using a longer tagline causes it to wrap over several times, resulting in a large amount of whitespace underneath the title, and making the whole header look unbalanced.

To reproduce:

Enter an average-length title, e.g. "My Wordpress Blog"
Enter a slightly longer tagline, e.g. "This is what happens when you have a slightly longer tagline than usual"

The tagline will be squashed over to the right, and a large white space opens up underneath the title, despite there being space for the string I suggested to appear on a single line.

Suggested fix: instead of fixing the width of the title and tagline to 700 and 220 pixels respectively, the widths should be set to "auto". The tagline could then be right justified. This produces a better-looking heading for a wider range of title and tagline length combinations.

Attachments (1)

twenty-ten-style-patch.diff (463 bytes) - added by jrawle 5 years ago.
Suggested patch to resolve this, if it's considered necessary

Download all attachments as: .zip

Change History (4)

#1 @zeo
5 years ago

  • Milestone changed from Unassigned to WordPress.org site

5 years ago

Suggested patch to resolve this, if it's considered necessary

#2 @SergeyBiryukov
4 years ago

  • Component changed from Themes to Bundled Theme
  • Keywords has-patch added

#3 @lancewillett
3 years ago

  • Milestone WordPress.org deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Prefer not to change this now since it could break layouts and customizations.

Note: See TracTickets for help on using tickets.