WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 2 years ago

#14011 closed defect (bug) (worksforme)

On subdirectory multisite installs, custom post types on main blog generate bad next/previous links

Reported by: jorbin Owned by: nacin
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords: needs-patch
Focuses: multisite Cc:

Description

With multisite and subdirectories, the main blog uses site.com/blog/xxx permalinks however custom post types can use site.com/custom/permalink . The next and previous post template tags generate the links as site.com/blog/custom/permalink .

Change History (9)

#1 @kevinB
7 years ago

  • Cc kevinB added

#2 @nacin
7 years ago

  • Milestone changed from Awaiting Review to 3.1
  • Owner set to nacin
  • Status changed from new to reviewing

This sounds like it is related to with_front, and that not being respected.

#3 @madtownlems
7 years ago

I'm commenting here because my other issue (#15360) was closed as a duplicate of this.
However, this ticket doesn't seem to contain the entirety of my situation and it's an issue I'd very much like to see resolved.

This ticket seems very narrow and only mentions custom post types on the main blog, but my ticket included all other blogs, without custom post types. Thanks.

(I have also confirmed the next_posts_link and previous_posts_link also behave incorrectly in my situation.)

#4 @nacin
7 years ago

madtownlems: Feel free to re-open. It sounded like a duplicate, but it looks like they're just related.

#5 @westi
7 years ago

What version did you find this in?

#6 @ryan
7 years ago

  • Milestone changed from 3.1 to Future Release

#8 @chriscct7
3 years ago

  • Focuses multisite added
  • Keywords needs-patch added

#9 @jeremyfelt
2 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from reviewing to closed

I attempted to reproduce this in a subdirectory configuration. The urls generated for next/previous on a custom post type were fine whether with_front was set to true or false. The /blog prefix was included and not included as expected.

I have a feeling this was resolved with other permalink work throughout the last years. If anybody continues to have this issue and can provide a reproducible steps, please reopen.

Note: See TracTickets for help on using tickets.