WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14016 closed defect (bug) (invalid)

Files directory inaccessible in MS upgrade from MU in blogs.dir/1/files.

Reported by: memitch08 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0
Component: General Keywords: Upgrade to 3.0, files path corrupted, bad htaccess updater
Focuses: Cc:

Description

I upgraded my WPMU sites to WP 3.0 RC1 - and updated nightly builds till the release of 3.0. With the auto upgrade of 3.0 - my url path to my files became inaccessible. Namely - blogs.dir/#/files. The issue is limited to the word "files".

I have .htaccess configured for re-write as:

# uploaded files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

I have tried to disable plugins, added Wordpress to WordPress filter plugin, manully upgrade - all to no avail.

I checked permissions on the folder, and my host says that the ownership of the directory is consistent with the other directories. The files are available through FTP access - but when putting the path to the file/image url in the browser - the WP 404 page appears.

This has happenned on all (3) of my WP upgrades.

Also - it should be noted that adding new files through image upload - shows the file name in the media library - but when I try to access the file I get the 404 page - so it is not isolated to old files.

See example:
If I put the file in the blogs.dir directory without any subdirectories then the file is accessible.

See here: http://hanover4square.org/wp-content/blogs.dir/4sqlogo.jpg

It is still fine here: http://hanover4square.org/wp-content/blogs.dir/1/4sqlogo.jpg

But if I move the same file to the files sub-directory within blogs.dir it is not accessible?

See here: http://hanover4square.org/wp-content/blogs.dir/1/files/4sqlogo.jpg

But if I create a sub-directory called file1 the file is accessible?

See here: http://hanover4square.org/wp-content/blogs.dir/1/file1/4sqlogo.jpg

To magically redirect it would be:
http://hanover4square.org/files/4sqlogo.jpg

But that returns a 404 too.

Please advise.

Change History (7)

comment:1 memitch084 years ago

Ok - I've changed all instances of the directory "files" to "uploads"

Changed this in .htaccess and under site editor URL paths -

Now I can upload files to the media libarary and they do show up in wordpress - however I'm thinking that the urls will also have to be updated in the database as well.

comment:2 memitch084 years ago

This has happened on all 5 of my WPMU installs/upgrades. Some of them I did not run the beta's on. Just upgraded from WPMU to WP 3.0 and am expiriencing the same issues.

comment:3 wpmuguru4 years ago

I couldn't reproduce this problem. I was able to request the file using either http://domain.com/path/files/2010/06/img.jpg or http://domain.com/path/wp-content/blogs.dir/1/files/2010/06/img.jpg.

comment:4 andrea_r4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

comment:5 nacin4 years ago

  • Milestone Awaiting Review deleted

comment:6 gazouteast4 years ago

  • Cc gazouteast added
  • Keywords Upgrade to 3.0 files path corrupted bad htaccess updater added
  • Resolution invalid deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened

wpmuguru — 3 weeks ago

"I couldn't reproduce this problem. I was able to request the file using either http://domain.com/path/files/2010/06/img.jpg or http://domain.com/path/wp-content/blogs.dir/1/files/2010/06/img.jpg."

Couldn't have tried very hard - did you try -

http://sub-blog.domain.com/path/files/2010/06/name-of-post
http://domain.com/sub-blog/path/files/2010/06/name-of-post

Because those are the paths that both WP site owners, their sub-blog admins, and site visitors, are going to use.

See - http://wordpress.org/support/topic/423138 - I'll be submitting two new tickets based on that thread, and one of them is a repeat of this trac topic.

comment:7 nacin3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.