Make WordPress Core

Opened 5 years ago

Closed 3 weeks ago

#14039 closed enhancement (duplicate)

Consolidate strings with same meaning but different wording

Reported by: demetris Owned by: demetris
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Text Changes Keywords:
Focuses: administration Cc:


While translating WordPress I often come upon couples or triplets of strings that mean the same thing but are worded differently. I would like to start consolidating such strings by selecting a preferable version and replacing the other instances with it.

Here is one example:

  • You are not allowed to edit this page. <- The one to keep.
  • Sorry, you cannot edit this page.
  • Sorry, you do not have the right to edit this page.

Here is another:

  • Submit Comment
  • Post Comment <- $label_submit in comment_form()

Before making any patches, I will post all cases here for review and feedback.

The milestone for this would be 3.1, but it seems that I have been designated an “unknown Trac user” and I cannot set milestone and priority.

Change History (16)

#1 @nacin
5 years ago

  • Milestone changed from Unassigned to 3.1

As explained, we are trying to prevent scope creep and improve our workflow. Given the dozens of us who read literally every ticket as they are posted, it makes sense to restrict a few fields (priority and milestone) to ensure they can be trusted and useful.

I am all for consolidating strings; patch away. I know Nikolay has talked about a review of all strings in core for inconsistent tone, word choice, similarity, etc., but it's quite the project that realistically needs to go through person to ensure consistency. (If you want to start offering huge patches to that effect, I will gladly assign this ticket to you.)

#2 @demetris
5 years ago

  • Owner set to demetris
  • Status changed from new to assigned


I assigned the ticket to myself. I will not be submitting huge patches soon (that is, not within the next few days). I want to look at the strings carefully.

Also, my initial plan was to use this ticket only for consolidation, not for standardization. That is, not for changes that will introduce new strings into the POT by tweaking and by fixing typos/capitalization/punctuation/etc. But I’ll see how that goes.

Standardization would introduce a large number of new strings. For an indication, see the different wordings we use now in messages about insufficient capabilities:

  • You are not allowed to
  • You do not have the right to
  • You do not have permission to
  • You do not have sufficient permissions to
  • You cannot


Feedback appreciated!

#3 @hakre
5 years ago

Related #14060

#4 @hakre
5 years ago

Related: #14972

#5 @nacin
5 years ago

  • Milestone changed from Awaiting Triage to Future Release

#6 follow-up: @demetris
4 years ago

Closed #18218 as duplicate of this.

#7 in reply to: ↑ 6 @ramiy
4 years ago

Replying to demetris:

Closed #18218 as duplicate of this.

Demetris, i don't think #18218 is a duplicate. This ticket presenting a concept and guidelines for the future, #18218 shows specific strings that can be changed right now.

Version 0, edited 4 years ago by ramiy (next)

#8 @ramiy
4 years ago

  • Cc r_a_m_i@… added

#10 follow-up: @scribu
4 years ago

+1 on taking care of the strings in #18218 now.

Better to break this into multiple steps.

#11 in reply to: ↑ 10 @ramiy
4 years ago

Replying to scribu:

+1 on taking care of the strings in #18218 now.

Better to break this into multiple steps.

scribu, also check out the paches i added to #7098, some of them related to the strings in #18218.

#12 @steveagl
4 years ago

  • Cc steveagl added

#13 @ocean90
3 years ago

  • Cc ocean90 added

#14 @SergeyBiryukov
3 years ago

  • Component changed from UI to Text Changes

#15 @chriscct7
7 months ago

  • Focuses administration added
  • Keywords needs-patch ux-feedback added

#16 @SergeyBiryukov
3 weeks ago

  • Keywords needs-patch ux-feedback removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

No patch and no traction here, closing as a duplicate of #34521 and #18218.

Note: See TracTickets for help on using tickets.