Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14056 closed defect (bug) (duplicate)

Wordpress is using wrong Jquery ui version

Reported by: DreadLox Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: JavaScript Keywords: javascript, jquery, jquery ui, ui
Focuses: Cc:


Wordpress 3.0 has Jquery Ui 1.7.3 and jquery v 14.2 whereas on their web site it is stated:

  • Stable (1.8.2: jQuery 1.4+)
  • Legacy (1.7.3: jQuery 1.3+)

So it may not be compatible. I there anything in core that relies to JUI 1.7.3 ??

Vest regards

Change History (2)

comment:1 @JDTrower5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12863.

The decision was made that there wasn't time to retest everything to ensure that Jquery UI 1.8 didn't break anything in WordPress 3.0 and so the decision was to wait until early in the 3.1 development cycle.

comment:2 @nacin5 years ago

  • Milestone Unassigned deleted

Also a duplicate of #13868.

UI 1.7.3 is indeed compatible with JQuery 1.4, in fact it was a maintenance release to ensure the 1.7 branch would work with 1.4. So we made sure to update to 1.7.3 in WP 3.0 and we'll revisit 1.8 in 3.1.

Note: See TracTickets for help on using tickets.