WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#14063 closed defect (bug) (invalid)

Twenty Ten i18n problems

Reported by: pavelevap Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

1) There are several strings in .pot file which were translated, but translations not displayed, for example "The 2010 default theme for WordPress." and "the WordPress team".

2) String "This gallery contains <a %1$s>%2$s photos</a>." is not ready for plural forms. In Czech there are "4 obrázky", but "5 obrázků".

3) There are problems with number of comments. Using comments_popup_link() in loop.php leads also to nonsense. There is only one plural form for my language, but we need 2.

4) Search results - when finding string in some page, there is "Posted in" nothing, because page is not in any category.

5) twentyten.pot file is generated from WordPress trunk (probably) or from Themes directory? It will be possible to update translation also in Themes directory to be available through automatic update? There is 1.0.3 version in Themes directory and when there would be new strings, they should be also translated through GlotPress...

Change History (11)

comment:1 @nacin5 years ago

  • Component changed from General to Themes
  • Milestone changed from Unassigned to WordPress.org site
  • Owner set to nbachiyski
  • Status changed from new to assigned

comment:2 @SergeyBiryukov5 years ago

  • Cc sergeybiryukov.ru@… added

comment:3 @SergeyBiryukov5 years ago

Now that we have _get_plugin_data_markup_translate(), shouldn't we also translate theme descriptions?

comment:4 @nacin5 years ago

These issues should be broken out into individual tickets otherwise they won't get addressed.

  1. We can probably do this. It needs its own ticket.
  1. This needs its own ticket.
  1. This is being addressed elsewhere.
  1. This needs its own ticket.
  1. The pot generated from the core repo. Is there a bug here?

comment:5 @pavelevap5 years ago

OK, thank you...

1) New ticket - #15858

2) New ticket - #15859

3) Yes, it is my another ticket - #13651

4) This problem is not confirmed in latest trunk.

5) So we can leave this ticket for this particular problem? There is no bug, but sync problems. Example is also with latest WordPress. Akismet is bundled with WordPress, but new version can be also released separately. So, I updated to WP 3.0.2 and then to Akismet 2.5.0. But suddenly, WP 3.0.3 appeared and after update I was back with Akismet 2.4.0 (because this version was bundled with WP). Not very user friendly.

And another problem is that Akismet is translated together with WordPress. But when there will be Akismet 2.6 (and no WordPress update), many strings can be untranslated. I am not sure about right solution, but Akismet should be removed from main WP translation and synced with specific plugin translation (and the same system should be applied for Twenty Ten). This should also avoid following problem - new Twenty Ten version released in Theme repository but no new WordPress version.

You can see discussion and proposal here: http://wppolyglots.wordpress.com/2010/12/10/proposal-for-plugins-localization-system/

Last edited 5 years ago by nacin (previous) (diff)

comment:6 follow-up: @nacin5 years ago

Twenty Ten pot is based on the latest trunk here. That is proper. You will never have untranslated strings there.

Akismet is another story. We don't control the Akismet release cycle directly, only what version we pin to. Ideally we will be unbundling and forcing Akismet to use its own pot and GlotPress subproject come 3.2.

comment:7 @zeo5 years ago

  1. Those pages got assigned to category. In _term_relationship table just delete any object_id that belongs to any post type Page.

comment:8 @SergeyBiryukov3 years ago

  • Component changed from Themes to Bundled Theme

comment:9 in reply to: ↑ 6 @SergeyBiryukov3 years ago

Replying to nacin:

Ideally we will be unbundling and forcing Akismet to use its own pot and GlotPress subproject come 3.2.

Related: #20882

comment:10 @SergeyBiryukov3 years ago

It will be possible to update translation also in Themes directory to be available through automatic update?

Related: #18200

comment:11 @SergeyBiryukov3 years ago

  • Milestone WordPress.org deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

Looks like all the points here are addressed in new tickets.

Note: See TracTickets for help on using tickets.