WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#14085 closed defect (bug) (duplicate)

Permalinks for pages bug

Reported by: zx0 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0
Component: Permalinks Keywords: permalinks
Focuses: Cc:

Description

When I use cyrillic permalinks for pages (probably other languages have the same bug) they doesn't work, I get 404 error. Moreover, if I use only one word for permalink (without dashes), e.g. "калькулятор", it redirects to "/category/без-рубрики/".

If I change permalink options to "/%pagename%/" they will work, but it will break posts everything.

Same time posts with cyrillic permalink works ok.
For newly created custom post types everything also works great.

Bug reproduced on clean installation of WP 3.0 and WP 2.9.2

Change History (2)

#1 @SergeyBiryukov
10 years ago

  • Cc sergeybiryukov.ru@… added

Seems to be a duplicate of #10249. Redirection of “калькулятор” to “/category/без-рубрики/” is not happening on my install, though. Can you try the patch from #10249 to see if it works?

#2 @nacin
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.