WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#14092 closed defect (bug) (fixed)

Strikethrough from visual editor being ignored/filtered

Reported by: markel Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.0
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Confirmed in 3.1-alpha.

Steps to reproduce:

  1. Open an existing post, or create a new one.
  2. Enter some text and highlight it, then apply the strikethrough properly using the visual editor.
  3. Either preview the post or switch over to HTML editing mode and back.
  4. The text will have returned to normal.

Change History (11)

comment:1 @markel5 years ago

The editor appears to be using <s> for the strikethrough text (according to the status area); since that tag is deprecated, should it use either a style or <del> instead?

comment:2 @nacin5 years ago

  • Cc azaozz added

comment:3 @nacin5 years ago

  • Milestone changed from Awaiting Review to 3.0.1
  • Priority changed from normal to high
  • Severity changed from normal to major

I noticed this the other day, but I forgot to look into it. This is a regression from 2.9, which properly uses the <del> tag.

comment:4 @nacin5 years ago

  • Milestone changed from 3.0.1 to Awaiting Review
  • Priority changed from high to normal
  • Severity changed from major to normal

My initial test lied, I started in HTML view (which works fine). Not a regression.

comment:5 @designsimply5 years ago

Behavior varies by browser. See #14229

comment:6 @azaozz5 years ago

It seems the <s> or <strike> tags are actually added by the browser's built-in editor (that's why they are different for different browsers). They are later replaced with a styled span for compatibility reasons. Unfortunately many browsers don't support all tags in contentEditable mode.

However I cannot reproduce the behavior reported in this ticket. Setting a few words or a whole paragraph to deleted (strike through) seems to work properly in both 2.9 and 3.0 (haven't tested in multi-site mode).

comment:7 @rmarks5 years ago

  • Cc rmarks@… added

I can confirm this bug exists in Chrome 5.0.396.0 beta. In my case, the post belongs to site number 2 of a multi-site install running version 3.0. The strike through is seen after highlighting the text and clicking the strikethrough button, but the markup is filtered when the post is updated. I was able to toggle to the HTML editor, apply the <del> tag, and successfully Update the post. I returned to the Visual editor and was able to see the strike through over the text. Subsequent saves of the post do not cause the strike through to be filtered.

comment:8 @iandstewart5 years ago

I can confirm this bug exists w/ Chrome and Safari. Adding a strikethrough effect by clicking the strikethrough button in the Visual Editor and then clicking Publish or the HTML tab will strip the tags from the content. Adding a del tag first in the HTML editor, clicking the Visual Editor tab and then moving back and forth between HTML and Visual or publishing will not strip it out.

comment:9 @uncleringo5 years ago

I can also confirm this as a bug. No one in our office can use strikethrough with google's chrome browser. With firefox it works fine.

My version of chrome is 5.0.375.55

comment:10 @nacin4 years ago

  • Component changed from Editor to TinyMCE
  • Milestone changed from Awaiting Review to 3.1

comment:11 @azaozz4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [16090], the visual editor now uses <del>.

Note: See TracTickets for help on using tickets.