WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#14138 closed defect (bug) (worksforme)

edit-comments.php does not display any posts when paginated

Reported by: dheerg Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0
Component: Comments Keywords: reporter-feedback
Focuses: Cc:

Description

In the wordpress admin, edit-comments.php?apage=x does not show any comments.

While without using the ?apage=x part the first page does show results, and to see older comments it is possible to increase the number of displayed comments, edit-comments.php?apage=1 does not show any results.

It is calculating the pagination correctly. Furthermore on inspecting the source it seems like the page is generating blank tr element equal to the number of comments it ought to be displaying, hence I guess it is a bug with the actual output from those queries.

I have tested this on two installs for established websites which I had upgraded recently, and two fresh installs on different servers, with no plugins and the default theme.

Change History (2)

comment:1 @mattloak5 years ago

  • Cc mattloak added

I am having the same issues on all my sites running 3.0.

comment:2 @nacin4 years ago

  • Keywords reporter-feedback added; edit comments pagination removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this on 3.0.x. Tested with and without Akismet.

This has all changed in 3.1 with #14579. Closing as worksforme pending more feedback.

Note: See TracTickets for help on using tickets.