WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14204 closed defect (bug) (duplicate)

wp-admin/upgrade-core.php always reports that we're at the latest version

Reported by: celejar0 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

I have tried repeatedly to upgrade my WP installation by navigating to the above page, but I always get:

"You have the latest version of WordPress. You do not need to upgrade"

even when I'm not at the latest version (e.g., at this time I'm running 2.9.2, and 3.0 is out).

The hosting provider doesn't allow outgoing network connections. Could that cause this problem? If so, I suggest that the code should detect this and respond accordingly.

Change History (5)

comment:1 in reply to: ↑ description nacin4 years ago

Replying to celejar0:

The hosting provider doesn't allow outgoing network connections. Could that cause this problem? If so, I suggest that the code should detect this and respond accordingly.

That would indeed cause that problem. A check couldn't hurt, though we'd have to differentiate between a few bad requests and the provider blocking it entirely.

Perhaps download the Core Control plugin and see if any other transports work on that host?

comment:2 nacin4 years ago

  • Component changed from Upgrade/Install to HTTP

comment:3 dd324 years ago

  • Component changed from HTTP to Upgrade/Install

The Core upgrade should detect that no valid HTTP response has been returned.

At present, Its likely expecting error means that its timed out, and the previous result is A-OK.

If no valid response is recieved, a warning should be displayed explaining outgoing connections cannot be made.

comment:4 nacin4 years ago

  • Milestone changed from Awaiting Review to Future Release

comment:5 dd323 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #16156 due to that ticket having more traction and a patch

Note: See TracTickets for help on using tickets.