WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#14211 closed defect (bug) (fixed)

Full Screen view in TinyMCE can destroy post

Reported by: RanYanivHartstein Owned by: azaozz
Milestone: 3.1 Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

In certain cases, switching to full screen view in TinyMCE can destroy a post's contents.

Here's one way to reproduce this.

  1. Get the file bad-full-screen.txt attached to this ticket
  1. Create a new post in any 3.0 blog
  1. Switch to HTML
  1. Paste from above file
  1. Update/publish (or anyway, save)
  1. Switch to Visual Editor
  1. Hit Full Screen

Now, the Full Screen view doesn't just hide the text, it removes it - when you switch back to normal view, the post is empty (except for a line break with mce_bogus="1").

This looks like it's caused by something in the last three paragraphs. When I paste the text in paragraph by paragraph, the paragraph that seems to be responsible is the one that starts with "To begin with, we're going to..." (the third paragraph from the end). For e.g., If I go through the above process, but between stage 8 and stage 9 I remove that paragraph, everything works fine.

Possibly related - #9950 , #7069

Attachments (1)

bad-full-screen.txt (40 bytes) - added by mdawaffe 10 years ago.
replacement file for originally submitted copyright content

Download all attachments as: .zip

Change History (5)

#1 @mdawaffe
10 years ago

I can reproduce the problem with just the string "undefined" as the post_content.

Furthermore, once in Visual mod with the string "undefined" as the post_content, I cannot switch back to HTML mode.

@mdawaffe
10 years ago

replacement file for originally submitted copyright content

#2 @mdawaffe
10 years ago

The originally submitted file was copyright. I replaced it with something generic (and smaller).

#3 @nacin
10 years ago

  • Milestone changed from Awaiting Review to 3.1
  • Owner set to azaozz
  • Status changed from new to assigned

#4 @azaozz
10 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

This seems fixed in TinyMCE 3.3 [16090], feel free to reopen if the word "undefined" still causes problems when switching to full screen.

Note: See TracTickets for help on using tickets.