WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#14213 closed defect (bug) (fixed)

Export Errors, Line 72

Reported by: missmoxie Owned by:
Milestone: 3.0.1 Priority: normal
Severity: major Version: 3.0
Component: Export Keywords:
Focuses: Cc:

Description

I recently upgraded a client to 3.0. We're migrating her and need to export her posts into smaller files from specific categories rather than one big export. WP3 says we can do this with the new selectors within the export area of the dashboard.

When I choose "all" and everything default, it exports my file without errors, but only exports *some* of the posts -- not all.

When I choose a specific category to export, all statuses, it exports the right category, though not all the posts.

When I choose a specific category and "published" as the status, it spits out the following errors:

Notice: Array to string conversion in /var/www/vhosts/clientacct/httpdocs/wp-includes/formatting.php on line 2773

Notice: Undefined variable: status in /var/www/vhosts/clientacct/httpdocs/wp-admin/includes/export.php on line 72

I really don't know what any of that means, so I Googled it and found these instructions here: http://core.trac.wordpress.org/ticket/14026

Downloading the recommended export.php file and replacing it removed the first error, but the 2nd persists. I *really* need to get this content exported smoothly and this looks like the most ideal way.

Is this a bug?

(All the plugins have been deactivated, so I don't believe there is any interference here.)

Change History (3)

#1 @nacin
10 years ago

  • Keywords export error removed
  • Milestone changed from Awaiting Review to 3.0.1

Confirmed.

#2 @nacin
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15367]) Use correct variable in export. fixes #14213 for trunk.

#3 @nacin
10 years ago

(In [15368]) Use correct variable in export. fixes #14213 for 3.01.

Note: See TracTickets for help on using tickets.