WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14220 closed defect (bug) (invalid)

can't specify theme option values containing 'quotes'

Reported by: slambert Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

I have a theme with options so users can select fonts. I started to add font stacks that had 2+ word names, like "Times New Roman" and these need to be wrapped in quotes. When selected, they work - the fonts change. The problem is, they don't show as selected in the pull down list when the page refreshes. Without quotes, they do.

info: the comparison function for seeing if a value is currently selected is probably not evaluating quotes correctly

+ this works for both single & double quotes contained inside strings written w/ either single or double quotes

Change History (1)

comment:1 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I'm thinking you're not escaping properly. If you escape, keep in mind you'll still need to compare the unescaped value.

Try the support forums: http://wordpress.org/support/

Note: See TracTickets for help on using tickets.