WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14229 closed defect (bug) (duplicate)

Can't use strikethrough in TinyMCE under Chrome

Reported by: RanYanivHartstein Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

When using Chrome (tested with Windows and Mac), the Strikethrough feature in TinyMCE doesn't work.

To reproduce this, open any post for editing under Chrome, and use TinyMCE to set a strikethrough (third button from the right by default). TinyMCE adds the tag <s>example</s>, and then removes it if you switch to HTML view or click Update/Publish.

On Firefox, for e.g., TinyMCE uses <strike>example</strike>, which then gets converted to <span style="text-decoration: line-through;">example</span>.

(Note that idealy, TinyMCE should probably just use <del>example</del>, like the HTML editor does.)

See more about this here:
http://losingit.me.uk/2010/04/05/the-case-of-the-disappearing-strikethrough-tags

Change History (3)

comment:1 RanYanivHartstein4 years ago

Did I say third from the right? I meant third from the left. It's only third from the right on RTL blogs. This issue is unrelated to RTL.

comment:2 designsimply4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14092

comment:3 scribu4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.