WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#14233 closed defect (bug) (worksforme)

WP 3 Editor Not Showing "Editing in Progress" Warnings

Reported by: sahaskatta Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.0
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

This is my first Trac ticket, so I appologize if formatted incorrectly.

My WP install has 1 Administrator, 3 Editors, and over 10 Authors/Contributors. The text editor would generally show a warning with a user's name if it was being edited when opened with versions prior to WP 3.0.

However since upgrade, we've realized we've continuously had several instances of accidentally overwriting our own edits. After some investigating, I found it was because WP was no longer showing the RED warning at the top.

I was able to reproduce the problem several times on my install. To isolate whether it was a plugin causing a problem, I created a fresh install and tried a few cases again. If a user is editing a post and an Editor opens the editor during that time, it no longer shows a warning.

I've also documented the issue in the forums here: http://wordpress.org/support/topic/419456?replies=4

Change History (4)

comment:1 mrmist4 years ago

That's odd, because I see almost the exact opposite. I can have a Page edited by one user, and then have that user navigate away and another user open the Page, and it'll show the big red "Warning: Somebody is currently editing this page".

Ahh - I see specifics may be important here. Pages seem to produce the warning, post edits do not....

comment:2 nacin4 years ago

  • Keywords reporter-feedback added

I can't reproduce this at all.

Related: #15130.

I'm betting it's a plugin.

comment:3 dd323 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Cant reproduce it either.

comment:4 nacin3 years ago

Possibly related: #16928.

Note: See TracTickets for help on using tickets.