Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#14236 closed enhancement (duplicate)

XML-RPC API Plugin Management

Reported by: dklon Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: XML-RPC Keywords: XML-RPC, plugin, API
Focuses: Cc:


Two patches, one for xmlrpc.php and the other for /wp-admin/includes/plugin.php that expose plugin management through the WP API.

Attachments (2)

xmlrpc-plugin-funcs.diff (2.4 KB) - added by dklon 5 years ago.
XML-RPC plugin functions
get-plugin-data.diff (128 bytes) - added by dklon 5 years ago.
Modified get_plugin_data() function

Download all attachments as: .zip

Change History (3)

5 years ago

XML-RPC plugin functions

5 years ago

Modified get_plugin_data() function

#1 @nacin
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the patches. Please use svn diff: http://core.trac.wordpress.org/#HowtoSubmitPatches.

Closing this as a duplicate of #10789, you can add the proper patches there, though I would look at what has been contributed there first.

Note: See TracTickets for help on using tickets.