WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14272 closed defect (bug) (invalid)

Visual Editor missing in some browsers

Reported by: envygeeks Owned by:
Milestone: Priority: normal
Severity: trivial Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

tinyMCEPreInit.go(); does not exist.

This bug was reported over six months ago on the forums. Still not fix?

Attachments (1)

14272.patch (842 bytes) - added by envygeeks 4 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 dd324 years ago

Can you provide a link to it on the forums?

Generally this is caused by an incomplete upload of WordPress. Try re-uploading wp-includes for a start.

comment:2 envygeeks4 years ago

I've submitted a patch file which shows the error and how I got it to work in all browsers (Safari, Firefox and Chrome [the browser I was having trouble with] and possibly other non-mainstream browsers). A link to some of the posts:

http://wordpress.org/support/topic/414300?replies=7 ~ this was the latest thread, which I ran into when I experienced the problem. The other thread I can find if you need it, it's the one I was able to date back six months.

envygeeks4 years ago

comment:3 dd324 years ago

What version of Chrome are you experiencing it with?

Can you check the value of the can_compress_scripts option? (hit wp-admin/options.php to find out), Do you know if your server has gzip enabled? Are you using a Proxy server? Any client-side HTTP Compression applications? etc.

This sounds very much like a Server or Client configuration issue, as that function exists for me.

Can you also try opening the Javascript console in Chrome (Menu -> Developer -> Javascript Console) and type in 'tinyMCEPreInit;', hit enter, Expand the Object result, and see if the go() method exists?

Here's what it looks like for me:

> tinyMCEPreInit
 Object
  base: "http://localhost/wordpress-commit/wp-includes/js/tinymce"
  go: function (){var b=this,a=tinymce.Scrip.............<snip>
  mceInit: Object
  query: "ver=327-1235"
  suffix: ""
  __proto__: Objec

comment:4 follow-up: envygeeks4 years ago

You are trying to convince me to do redundant things I have already stated in the forum thread I already did.
I'm not new to programming or debugging. However, I will amuse you:

Object
base: "http://test01.cluster08.localhost.com/wp-includes/js/tinymce"
load_ext: function (url,lang){var sl=tinymce.ScriptLoader;sl.markDone(url+'/langs/'+lang+'.js');sl.markDone(url+'/langs/'+lang+'_dlg.js');}
mceInit: Object
query: "ver=327-1235"
suffix: ""
__proto__: Object

Just to further amuse you it worked in Firefox, but not Chrome or Safari.
Also, just to point out, looking at: http://core.trac.wordpress.org/browser/branches/3.0/wp-includes/js/tinymce/tiny_mce.js shows tinyMCEPreInit.go is missing as well...

comment:5 in reply to: ↑ 4 nacin4 years ago

  • Keywords tinymce visual editor removed

Replying to envygeeks:

You are trying to convince me to do redundant things I have already stated in the forum thread I already did.
I'm not new to programming or debugging. However, I will amuse you:

I doubt dd32 was accusing you of anything. It works for him, it works for me, it works for 5.2 million others, so due diligence is quite important when tracking down a bug.

Also, just to point out, looking at: http://core.trac.wordpress.org/browser/branches/3.0/wp-includes/js/tinymce/tiny_mce.js shows tinyMCEPreInit.go is missing as well...

That's cause it's in wp-tinymce.js.gz. Here's the ungzipped version:
http://core.trac.wordpress.org/changeset/14765/trunk/wp-includes/js/tinymce/wp-tinymce.js

For some reason you are getting served tiny_mce.js, I imagine since your site is refusing to serve (or browser refusing to accept) the gzipped version?

comment:6 envygeeks4 years ago

After you brought that up I actually took a look around, I'll be submitting a proper patch to the problem in a few minutes, it's actually kind of both Chromes and Wordpress's fault at the same time.

comment:7 follow-up: envygeeks4 years ago

  • Resolution set to invalid
  • Severity changed from normal to trivial
  • Status changed from new to closed

I wasn't able to figure out definitively who's fault it was, but after I looked into it even deeper than before, I noticed it only happened with www on the domain, actually, it seems like it's all Chromes fault because the file serves properly without flaw without www but with www it serves stale caches, even with all the cache databases removed...

comment:8 scribu4 years ago

  • Milestone Awaiting Review deleted

comment:9 in reply to: ↑ 7 azaozz4 years ago

Replying to envygeeks:

... it seems like it's all Chromes fault because the file serves properly without flaw without www but with www it serves stale caches, even with all the cache databases removed...

Yes, it seems Chrome and Opera have very aggressive memory caching that makes it harder to instantly refresh scripts and CSS.

Just to clarify: tinyMCEPreInit.go() has to run when wp-tinymce.js.gz is loaded (it contains the TinyMCE core (tiny_mce.js) plus all of the plugins from wp-includes/js/tinymce/plugins/ plus the go() function itself).

However there is some room for improvement: the go() function doesn't have to be called from outside of wp-tinymce.js.gz, it can be run as lambda function after loading it. As this is an improvement it will be changed in WordPress 3.1.

Note: See TracTickets for help on using tickets.