WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14298 closed enhancement (fixed)

Twenty Ten: new description and stylesheet cleanup

Reported by: lancewillett Owned by:
Milestone: 3.0.1 Priority: normal
Severity: normal Version: 3.0
Component: Themes Keywords: has-patch
Focuses: Cc:

Description

  1. Better description. Feel free to tweak or suggest improvements. :)
  2. CSS cleanup. Add comment flags to main sections, spacing and formatting fixes, remove extra line endings, and add missing semicolons. I did not change any values -- patch only has format and spacing changes.

Attachments (3)

new-description.diff (1.0 KB) - added by lancewillett 4 years ago.
style.css-cleanup.diff (15.2 KB) - added by lancewillett 4 years ago.
new-description-revised.diff (1.0 KB) - added by lancewillett 4 years ago.
Revised description

Download all attachments as: .zip

Change History (17)

comment:1 lancewillett4 years ago

  • Cc lance@… added
  • Keywords has-patch needs-testing dev-feedback added

comment:2 nacin4 years ago

  • Keywords needs-testing dev-feedback removed

Description looks good. I read through the style.css cleanup and confirmed that the patch stuck to formatting.

comment:3 follow-up: zeo4 years ago

Glad that you raise this issue again. http://core.trac.wordpress.org/ticket/13881#comment:2

But there's 1 more thing. I'm not sure whether this is the current habit or trend, but why this:

selector {
...
}
selector-2 {
...
}

instead of:

selector {
...
}

selector-2 {
...
}

comment:4 in reply to: ↑ 3 ; follow-up: lancewillett4 years ago

Replying to zeo:

But there's 1 more thing. I'm not sure whether this is the current habit or trend, but why this:

There should be no extra lines between declaration blocks. I'm working on a CSS code standards doc for the Codex with all this information (will publish it soon).

lancewillett4 years ago

Revised description

comment:5 lancewillett4 years ago

Replying to nacin:

Description looks good.

Attaching an improved, trimmed up version with help from iandstewart.

comment:6 follow-up: nacin4 years ago

Matt suggested s/2010 default theme/2010 theme/

comment:7 in reply to: ↑ 6 lancewillett4 years ago

Replying to nacin:

Matt suggested s/2010 default theme/2010 theme/

Works for me. Future-proof, also gives us motivation for the next default theme. :)

comment:8 nacin4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15413]) Twenty Ten: Rename to appease the theme directory gods, version bump, and new description from lancewillett and iandstewart. fixes #14298.

comment:9 nacin4 years ago

(In [15414]) Twenty Ten 1.0.4. This is [15413] for 3.0. see #14298.

comment:10 nacin4 years ago

(In [15415]) style.css cleanup. props lancewillett, see #14298 for 3.0.

comment:11 nacin4 years ago

(In [15416]) style.css cleanup. props lancewillett, see #14298 for trunk.

comment:12 in reply to: ↑ 4 zeo4 years ago

Replying to lancewillett:

There should be no extra lines between declaration blocks. I'm working on a CSS code standards doc for the Codex with all this information (will publish it soon).

Still, no concrete reason. Please provide one (or more). For readability sake, please add new line after each block.

Did you realize if you're making this a standard, then all existing stylesheet in WP core, WP themes repo should be updated.

comment:13 scribu4 years ago

  • Milestone changed from Awaiting Review to 3.1

comment:14 nacin4 years ago

  • Milestone changed from 3.1 to 3.0.1
Note: See TracTickets for help on using tickets.