WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14316 closed defect (bug) (invalid)

Custom Menus - page link HREFs dont update when page slugs are modified

Reported by: adambundy Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Menus Keywords: reporter-feedback
Focuses: Cc:

Description

When a page that is appearing in a custom menu has its page slug updated, it doesn't change in its HREF in the custom menu, necessitating a delete and re-add.

Change History (2)

comment:1 filosofo4 years ago

  • Keywords reporter-feedback added; custom menus permalinks removed

By "custom menu," do you mean "custom link"? Those will not sync to anything, as they stand alone.

Page menu items added to a menu do change their links if the associated page's slug changes. Or at least I cannot reproduce something else.

Could you elaborate the steps to reproduce the issue? Are all plugins, particularly caching ones, deactivated?

comment:2 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.