WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 15 months ago

#14333 closed enhancement (duplicate)

Better page ordering UI

Reported by: ramiy Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Posts, Post Types Keywords: has-patch good-first-bug
Focuses: ui, javascript, administration Cc:

Description (last modified by scribu)

Unkile posts, in pages we can order and re-order the pages (using "menu_order" field in "wp_posts" table).

But since the new "Custom Menu" feature was introduced, do we realy need the page ordering?

We can create new menus, add as many pages as we like and re-order them as we like (this is the purpose of menues).

If we can do this using menus, then we can delete the ordering feature from the page editing screen.

Attachments (1)

14333.diff (3.5 KB) - added by scribu 3 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 @scribu5 years ago

  • Milestone changed from Awaiting Review to Future Release

It's way too early to be thinking about this. There are a many many themes that don't support menus yet.

comment:2 @knutsp5 years ago

Too early to remove this column from the database. But since WorPress knows if the active theme supports menus, and if there is at least one menu created, the UI field for the menu order of a page may be removed in the case. A theme or a plugin may also bring the UI back, even if the theme supports menus, but no menues are yet created.

A visible "menu order" for pages may be misleading and confusing for new users of WordPress, using Twenty Ten or another menu aware theme, not knowing the history of WordPress.

This dependant UI removal may be a way to prepare for a future removal of the menu_order column. WordPress 3.0 made this field practically obsolete. Some day it should be marked as such and then removed.

comment:3 @ramiy4 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

comment:4 @jameslaws4 years ago

Just wanted to throw my two cents in, I don't think this should ever be removed. There are way to many uses for the menu_order for automated listing where you don't want to have to create menus each time. Sometimes listing the pages is the best method but menu order is still the sorting method.

Just my opinion.

comment:5 @scribu4 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Although the menu_order field probably isn't going away, I agree that the curret UI should be removed.

Besides being redundant now, it was never very user friendly in the first place.

comment:6 @scribu4 years ago

  • Component changed from Database to Administration
  • Description modified (diff)
  • Summary changed from Database: Since the new "Custom Menu" feauter do we need the page order? to Remove page order UI

Gonna repurpose this ticket.

comment:7 follow-up: @scribu4 years ago

  • Description modified (diff)

comment:8 in reply to: ↑ 7 ; follow-up: @jameslaws4 years ago

Replying to scribu:

I completely agree with you. I was more referring to the idea of removing the column from the db than anything else. I would fight to make sure that doesn't happen. :) Extremely useful.

comment:9 in reply to: ↑ 8 @mikeschinkel4 years ago

  • Cc mikeschinkel@… added

Replying to jameslaws:

Replying to scribu:


I was more referring to the idea of removing the column from the db than anything else. I would fight to make sure that doesn't happen. :) Extremely useful.

+1 to that!

@scribu3 years ago

comment:10 @scribu3 years ago

  • Keywords has-patch added
  • Milestone changed from Future Release to 3.5

Hey, since we're hiding the UI for the Link Manager and for several superfluous options, how about this?

comment:11 follow-up: @DrewAPicture3 years ago

  • Cc xoodrew@… added

-1 for this.

To a certain extent, yes, menus have made it much easier to reorder content, but only if you plan on using menus to list content. And what about other custom post types that support page-attributes?

I'm fully aware we're not talking about removing the field, just the UI, but short of having to install a plugin to manually reorder, you're basically then stuck with whatever the default ordering is when invoking menu_order (unless I'm missing something). That's lame.

By all means, remove the bits from the meta box on the edit screen and quick edit, but either replace the ui/ux in the list tables (drag n drop?) or leave it alone.

comment:12 in reply to: ↑ 11 ; follow-up: @scribu3 years ago

  • Keywords 2nd-opinion added; dev-feedback removed
  • Milestone changed from 3.5 to Future Release

To a certain extent, yes, menus have made it much easier to reorder content, but only if you plan on using menus to list content.

Are you saying people use menu_order to display a full list of pages, with content and all?

And what about other custom post types that support page-attributes?

What about them? The UI is the same, still sucky.

By all means, remove the bits from the meta box on the edit screen and quick edit, but either replace the ui/ux in the list tables (drag n drop?) or leave it alone.

I agree with that. It's easy to fall into the trap of removing features in the name of simplicity, without providing alternatives. A current example from the Linux world: http://www.omgubuntu.co.uk/2012/08/ubuntu-12-10-will-ship-with-older-version-of-nautilus

comment:13 in reply to: ↑ 12 @DrewAPicture3 years ago

Replying to scribu:

To a certain extent, yes, menus have made it much easier to reorder content, but only if you plan on using menus to list content.

Are you saying people use menu_order to display a full list of pages, with content and all?

Actually, I was thinking more along the lines of wp_list_pages(). Sometimes dealing with the extra markup and overhead of a menu is just overkill.

Version 0, edited 3 years ago by DrewAPicture (next)

comment:14 @helenyhou3 years ago

There are definitely times that one might use the menu order, especially if it's not a menu that's the output :) Lists of child pages within content, utilizing the menu order to order alternate kinds of content (slides in a slider or some such), etc. There are some plugins that address it nicely in terms of drag-and-drop experience, such as http://wordpress.org/extend/plugins/simple-page-ordering/, but even then we'd have to think of what the no-JS/accessible alternative interaction would be.

comment:15 @jeremyfelt15 months ago

  • Focuses ui added

comment:16 @helen15 months ago

  • Keywords good-first-bug added; 2nd-opinion removed
  • Summary changed from Remove page order UI to Better page ordering UI

Man, 17 month ago me wasn't doing too shabby. Would still love to see what we could do to have a better page ordering interaction - wouldn't be surprised if there are some other duplicate tickets kicking around. Maybe no-JS support is as simple as keeping the field and hiding it when JS is available, and we can look into accessibility links like the menus system has. The checkbox column has some vertical space, could do arrows, maybe.

I guess there are some base issues with drag-and-drop, though, like what you do over a page break in the list table. Anybody want to explore this some more? The plugin is a great start (and not just saying that out of bias).

Also marking as a good-first-bug - not necessarily a walk in the park, but pretty self-contained.

comment:17 @helen15 months ago

  • Focuses javascript added

comment:18 @nacin15 months ago

  • Component changed from Administration to Posts, Post Types
  • Focuses administration added

comment:19 @helen15 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #2702.

Annnnd this is a duplicate.

Note: See TracTickets for help on using tickets.