WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#14335 closed defect (bug) (fixed)

Menu Pages Search does not return results

Reported by: mrmist Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.0
Component: Menus Keywords: has-patch needs-testing
Focuses: Cc:

Description

The menu Pages Search function used to find Pages to add does not seem to return any results for any searches. No matter what I type in the search box, it says "No Results Found".

Attachments (2)

noresults.jpg (56.2 KB) - added by mrmist 7 years ago.
14335.diff (32.8 KB) - added by scribu 7 years ago.

Download all attachments as: .zip

Change History (8)

#1 @duck_
7 years ago

  • Keywords reporter-feedback added

Cannot reproduce. Have you checked browser console for any JS errors? (If there are any it could be plugin/theme interference). Is it specifically the Pages search which doesn't work or are all post types/taxonomies searches not working?

#2 @mrmist
7 years ago

  • Keywords reporter-feedback removed

Hi

This is showing both on my test site (which has no active plugins) and live (which does). Both are different web platforms. I've checked in both IE and Opera, which you'd hope would remove browser specific issues.

Also attached a screenshot. You can see there is a page already in the menu called Fireman Set, but a search for Fireman gives nothing. (Admittedly that may be because that particular entry is already in the menu, but it's the same no result for everything.)

Category search does seem to return some results.
(Live runs 3.0, test site is against trunk)

@mrmist
7 years ago

#3 @scribu
7 years ago

Confirmed on a remote install. Works on localhost.

Additionally, the Categories search doesn't work either.

#4 @scribu
7 years ago

  • Keywords has-patch needs-testing added
  • Milestone changed from Awaiting Review to 3.1

It turns out the regex that split the elements was faulty.

In 14335.diff the items are first transformed into DOM nodes before being manipulated.

@scribu
7 years ago

#5 @mrmist
7 years ago

Confirming that the 14335.diff patch fixes my original test case. (The search itself seems a little slow but the test site has a lot of pages)

#6 @scribu
6 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.